Bug 237700 - %packages @Everything is broken
%packages @Everything is broken
Status: CLOSED DUPLICATE of bug 227383
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 16:30 EDT by Fred Feirtag
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 16:15:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Feirtag 2007-04-24 16:30:15 EDT
Description of problem:
Within a ks.cfg file:
> %packages
> @Everything
Does not work. Nor does it appear that the statement:
"Packages can be specified by group or by individual package name, including
with globs using the asterisk."
From here:
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Installation_Guide-en-US/s1-kickstart2-packageselection.html
is correct, since
> %packages
> *
returns
> %packages
> @base
> @core
> qt
in /root/anaconda-ks.cfg having matched only "qt", and
NOT globbing to match all packages.

Although the interactive "everything" on FC6 also appears
to have been removed, the "everything" kickstart still
works in FC6.  Everything installs are particularly useful
for creating diskless servers, where the client's hardware
(such as graphics hardware) may differ from the servers.
Moreover, it's far better to consume an extra GB of disk,
for most people, than to have to go back and yum install
even one package.  The nucleus of every cell in the body
contains all of the DNA, notwithstanding the fact that
different kinds of cells actually use only some differing
sequences.  It's better that way in multi-cellular animals,
and it's better that way in software.  Some 8 or 9 years
ago I requested an "everything" option be included, and
for years have been happy that it existed, perhaps in part
due to my request.  I hope that it will be restored.
Possibly an extra option "everything minus non-english
language packages" would be desirable for many.

Until then,
bash-3.00# cd repodata
bash-3.00# echo %packages > /tmp/ks.cfg-packages
bash-3.00# sed -n '/<id>/ {s/.*<id>\([^<]*\).*/@\1/; /-support/d; p;}' comps.xml
>> /tmp/ks.cfg-packages
bash-3.00# echo @legacy-software-support >> /tmp/ks.cfg-packages
bash-3.00# sed -n '/<packagereq type="optional">/ {s/.*al">\([^<]*\).*/\1/; p;}'
comps.xml >> /tmp/ks.cfg-packages

however, to make kickstart happy, 16 lines of this must be deleted:
gpart
lha
libica
openssl-ibmca
ddd
libpng10-devel
perl-Cyrus
salinfo
inkscape
httpd-suexec
base-system
desktops
apps
servers
development
xen

Ideas?

Thanks,
Fred Feirtag
ffeirtag@integrityns.com
Comment 1 Red Hat Bugzilla 2007-06-11 23:49:06 EDT
requested by Jams Antill
Comment 2 Chris Lumens 2007-08-23 16:15:30 EDT

*** This bug has been marked as a duplicate of 227383 ***

Note You need to log in before you can comment on or make changes to this bug.