Bug 237707 - GFS vector read-write (readv-writev) not working
Summary: GFS vector read-write (readv-writev) not working
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Wendy Cheng
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-24 21:11 UTC by Wendy Cheng
Modified: 2010-01-12 03:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-04 14:24:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wendy Cheng 2007-04-24 21:11:22 UTC
Description of problem:

Some VFS hooks have been changed between RHEL 4 (2.6.9 based kernel)
and RHEL 5 (2.6.18 based kernel). One noticable difference is vector 
read-write system calls (readv and writev). It uses plain filesystem 
read and write calls in 2.6.9 kernel but invokes aio_read and aio_write 
in 2.6.18 (and after) kernel. Unfortunately, GFS1 AIO code is mostly 
2.6.9 base that takes only one single user buffer. This breaks GFS1 
readv() and writev() in multiple buffers cases.

Version-Release number of selected component (if applicable):
RHEL 5 and CVS head

How reproducible:
always

Comment 1 Wendy Cheng 2007-04-24 21:22:16 UTC
GFS2 is immune from this issue since it uses VFS generic calls. 

Comment 3 Wendy Cheng 2007-05-04 02:10:09 UTC
ah ? not sure the kernel base I was when I wrote this bugzilla... I checked
the code again today .. the kernel uses plain gfs_write.... !!!!!

Comment 4 Wendy Cheng 2007-05-04 02:28:29 UTC
oh, I see... I was in Steve's nmw tree... so

GFS1 readv-writev, togather with NFS read-write, will be broken in most 
recent upstream kernel but it is still ok with RHEL5 kernel. 

Maybe I should cancel this bugzilla.. 

Comment 5 Wendy Cheng 2007-05-04 02:30:04 UTC
On the other hand, this means our GFS1 in CVS head is broken now. 

Comment 6 Wendy Cheng 2007-05-04 02:59:44 UTC
Worse than I expect in CVS head .. the AIO code there doesn't look familar 
at all (did I do that ?) and it is very wrong. So three pieces are wrong in 
GFS1 cvs head:

1. AIO
2. Readv-Writev
3. NFS 




Comment 7 Wendy Cheng 2007-05-04 03:02:35 UTC
To recap..

RHEL4 is ok
RHEl5 is ok
CVS head is broken.

I'll continue tomorrow. 

Comment 8 Wendy Cheng 2007-05-04 03:20:50 UTC
Ha! Just check CVS log - I knew it wasn't me :) .. Will fix it tomorrow. 

Comment 9 Wendy Cheng 2007-05-04 14:24:21 UTC
Close this bugzilla since RHEL 5 doesn't have this issue. 

Comment 10 Nate Straz 2007-12-13 17:42:34 UTC
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Comment 11 Nate Straz 2007-12-19 20:06:37 UTC
Moving all closed bugs to gfs-kmod to match the rpm name.  GFS-kernel will be
removed.


Note You need to log in before you can comment on or make changes to this bug.