Bug 237709 - system-config-soundcard crashes on powerbook, breaking firstboot
system-config-soundcard crashes on powerbook, breaking firstboot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 17:36 EDT by Will Woods
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-28 09:27:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback from firstboot (1.18 KB, text/plain)
2007-04-24 17:36 EDT, Will Woods
no flags Details
scsrun.log from failed run of system-config-soundcard (10.68 KB, text/plain)
2007-04-30 15:37 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2007-04-24 17:36:54 EDT
On my powerbook, firstboot crashes while trying to load the
system-config-soundcard page. The traceback is attached.
Comment 1 Will Woods 2007-04-24 17:36:54 EDT
Created attachment 153389 [details]
traceback from firstboot
Comment 2 Martin Stransky 2007-04-25 02:32:28 EDT
Can you please run system-config-soundcard from console and attach the output?
and attach /root/scsconfig.conf (it can be genetared by system-config-soundcard,
in "System" tab")
Comment 3 Will Woods 2007-04-30 15:35:59 EDT
No output on the console, but I will attach the resulting scsrun.log, which
contains basically the same traceback.
Comment 4 Will Woods 2007-04-30 15:37:13 EDT
Created attachment 153815 [details]
scsrun.log from failed run of system-config-soundcard
Comment 5 Will Woods 2007-05-08 14:35:39 EDT
Okay, I traced it myself. This is crashing because the alsa playback device for
snd_powermac does not have info.vendor, nor do any of its parents.

Furthermore, getVendor() in soundcardHalBackend.py doesn't have a fallback for
this case. It just returns "None", causing a traceback.

I suspect we might need a workaround for snd_powermac - probably some fdi to add
info.vendor = "Apple Computer Inc" to snd_powermac devices - but getVendor()
should return something reasonable if it fails.
Comment 6 Jeremy Katz 2007-05-21 14:59:10 EDT
Per the hal spec
(http://people.redhat.com/davidz/hal-spec/hal-spec.html#device-properties-info),
info.vendor isn't a mandatory property to be present for devices.

For F-7, I've committed the very minimal handling of the fallthrough when the
vendor isn't found to at least avoid things crashing.  Post F7, this should be
reworked a bit more (so leaving open for that)
Comment 7 Martin Stransky 2007-05-28 09:27:20 EDT
fixed in system-config-soundcard-2.0.6-6.fc6

Note You need to log in before you can comment on or make changes to this bug.