Bug 237733 - "innd: SERVER cant listen RCreader Address already in use" on startup
"innd: SERVER cant listen RCreader Address already in use" on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inn (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 22:53 EDT by Jonathan Kamens
Modified: 2008-01-16 08:32 EST (History)
0 users

See Also:
Fixed In Version: inn-2.4.3-9.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 08:32:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2007-04-24 22:53:18 EDT
Innd has started logging "innd: SERVER cant listen RCreader Address already in
use" on startup.  Here's a fragment of /var/log/news/news.notice:

Apr 24 22:32:19 jik2 innd: SERVER perl filtering disabled
Apr 24 22:32:20 jik2 innd: SERVER shutdown shutting down
Apr 24 22:35:29 jik2 innd: SERVER descriptors 1024
Apr 24 22:35:30 jik2 innd: SERVER outgoing 1011
Apr 24 22:35:31 jik2 innd: SERVER ccsetup control:14
Apr 24 22:35:32 jik2 innd: SERVER lcsetup localconn:16
Apr 24 22:35:34 jik2 innd: SERVER rcsetup remconn:3
Apr 24 22:35:37 jik2 innd: SERVER cant listen RCreader Address already in use
Apr 24 22:35:39 jik2 innd: news-transport.mit.edu opened
news-transport.mit.edu:18:file

The log message does not appear to have any ill effects (i.e., I can still
transport and read news), but it is disconcerting nevertheless and should be
fixed if it's a meaningless log message.

I have inn-2.4.3-6.fc6.

I've perused the config files and can't figure out what might be causing the error.
Comment 1 Ondrej Vasik 2008-01-07 16:01:55 EST
Sorry for delay, I became maintainer of inn today. Thanks for report, it is
caused by switched lines in the code of innd(file rc.c). Error address already
in use is considered as nonterminal, because some IPv6 systems already listening
on any address will return EADDRINUSE when trying to listen on the IPv4 socket.
Anyway, it should be fixed as it could be a bit confusing. Will do that in next
rawhide build.
Comment 2 Ondrej Vasik 2008-01-16 08:32:54 EST
Fixed in inn-2.4.3-9.fc9 , will not backport to FC-6,F7,F8 as it is not critical
issue and is in fact harmless. Closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.