Bug 237748 - Java (and other) software crashes when prelink is disabled or /etc/ld.so.cache exists.
Java (and other) software crashes when prelink is disabled or /etc/ld.so.cach...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: glibc (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 04:18 EDT by Rik Theys
Modified: 2009-10-20 08:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-20 08:53:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik Theys 2007-04-25 04:18:36 EDT
Description of problem: software (such as Matlab, but also simple java code)
that uses java crashes on a stock RHEL5 install with prelink disabled.

This seems related to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=222288

The sample code in that bugreport crashes on x86_64 RHEL5 systems with prelink
disabled. If prelink is enabled (and run), the program works. It also works when
/etc/ld.so.cache is removed (with prelink disabled).


Version-Release number of selected component (if applicable):

java version "1.6.0"
Java(TM) SE Runtime Environment (build 1.6.0-b105)
Java HotSpot(TM) 64-Bit Server VM (build 1.6.0-b105, mixed mode)

glibc-2.5-12


How reproducible: Always


Steps to Reproduce:
1. disable prelink (prelink -ua)
2. run the java program mentioned in RH bugzilla bug 222288
3. program crashes
4. enable prelink (prelink -a)
5. program works

Another way to reproduce is:
1. disable prelink (prelink -ua)
2. run the code
3. program crashes
4. remove /etc/ld.so.cache
5. run the program -> WORKS
6. run ldconfig (to create /etc/ld.so.cache)
7. run program -> CRASH


Actual results:

java crashes

Expected results:

no crash and example java application returns "OK"

Additional info:

Other software also crashes/fails to start when prelink is disabled. Matlab
crashes with 'failed to load the Desktop class'.

It shouldn't matter if prelink is enabled or not. 

If /etc/ld.so.cache is removed (with prelink disabled), the program works. It
should not matter to ld if the cache file exists or not. The result should be
the same.

This only seems to affect x86_64 machines. I've been unable to reproduce this on
i386 systems.
Comment 1 Jakub Jelinek 2007-07-19 09:31:54 EDT
This is supposed to be fixed in glibc-2.5-18, which will show up in RHEL5.1.
Comment 2 Rik Theys 2007-07-20 02:07:58 EDT
Where can I download glibc-2.5-18? What is the release schedule for RHEL5.1?

Note You need to log in before you can comment on or make changes to this bug.