Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 237761 - Maximising windows sometimes doesn't resize them
Maximising windows sometimes doesn't resize them
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks: 237760
  Show dependency treegraph
 
Reported: 2007-04-25 05:49 EDT by Bastien Nocera
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 08:38:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nautilus-maximise.png (31.29 KB, image/png)
2007-04-25 05:49 EDT, Bastien Nocera
no flags Details
terminal-maximise.png (11.92 KB, image/png)
2007-04-25 05:50 EDT, Bastien Nocera
no flags Details
maximised.png (104.07 KB, image/png)
2007-04-25 10:38 EDT, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2007-04-25 05:49:35 EDT
compiz-0.3.6-8.fc7

1. Maximise a window
2. Unmaximise a window
3. Go back to 1.

After usually 5 or 6 cycles, the window contents will not be updated, and will
be stuck to the old size.

Screenshots with gnome-terminal and nautilus showing the problem
Comment 1 Bastien Nocera 2007-04-25 05:49:36 EDT
Created attachment 153403 [details]
nautilus-maximise.png
Comment 2 Bastien Nocera 2007-04-25 05:50:34 EDT
Created attachment 153404 [details]
terminal-maximise.png
Comment 3 Bastien Nocera 2007-04-25 10:38:26 EDT
Created attachment 153423 [details]
maximised.png

Sometimes, it has some very interesting behaviours... As can be seen in this
screenshot, the minimise button became huge, and whole title bar decorations
started acting bizarrely.
Comment 4 Pancrazio `ezio' de Mauro 2007-07-02 07:58:52 EDT
I can reproduce exactly the same since Fedora Core 6, in addition all input
going to the window does not show up until the window is un-maximised, leaving
the user to believe that the window is actually frozen
Comment 5 Bastien Nocera 2007-10-12 08:38:19 EDT
Doesn't seem to happen anymore in rawhide.

Note You need to log in before you can comment on or make changes to this bug.