Bug 237766 - Panels on second screen don't show on right and bottom positions
Panels on second screen don't show on right and bottom positions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 06:35 EDT by erik slagter
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: gnome-panel-2.18.0-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 08:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description erik slagter 2007-04-25 06:35:03 EDT
Description of problem:

On my second screen (:0.1) panels that are placed on bottom and right positions
are invisible, the desktop is shown instead. The space it's supposed to occupy
is taken from existing full-screen windows though. So, if you have a full-screen
window and enable a bottom or right positioned panel, the full-screen window is
shrunk by the size of the panel, the desktop is shown at that position, but
there is no panel to be seen. Richt-clicking on this bar gives a nautilus
context-menu.

Version-Release number of selected component (if applicable):

gnome-panel-2.18.0-9.fc7

How reproducible:

Easiest way: enable dual-monitor operation with dual-screen (i.e. no merged
framebuffer), create a panel on the top (otherwise you'll lose it immediately),
click properties and adjust it to be a bottom or right panel, and watch it
disappear. Then of course revert it before OKing it, otherwise your panel will
be lost (but stil float around in the settings :-().

Actual results:

A strip of desktop where I expect a panel.

Expected results:

A panel.

Additional info:

There is a related problem, although it probably isn't caused by panel, I don't
know what application.

When the panel is stopped (by removing it from the session, that seems to be the
only way), and a window is maximised on the second screen (:0.1), the window's
size extends way beyond the actual screen size. This is not an X problem because
xdpyinfo reports the proper screen size. Also when the panel is started, the
problem goes away. Weird. I will report this as a metacity bug as well.

Note You need to log in before you can comment on or make changes to this bug.