Bug 237785 - yumex crash upon malformed proxy url {e.g.: "localhost:8080" - missing http, ftp or https}
Summary: yumex crash upon malformed proxy url {e.g.: "localhost:8080" - missing http, ...
Status: CLOSED DUPLICATE of bug 229523
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-25 13:38 UTC by Shlomi Hazan
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 09:04:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shlomi Hazan 2007-04-25 13:38:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.10) Gecko/20070409 CentOS/1.5.0.10-2.el5.centos Firefox/1.5.0.10

Description of problem:
yumex crashes upon setting of a malformed proxy url (e.g.: "localhost:8080"), which is missing the protocol part (http, ftp or https).

* routine: 
BackgroundRunner
* error: 
Error parsing 'localhost:8080': URL must be http, ftp or https not "localhost"
* dump:
Component: yumex
Version: 1.2.2
Summary: TB03120a34 yumexmain.py:1045:_runBackground:ValueError: Error parsing 'localhost:8080': URL must be http, ftp or https not "localhost"

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 231, in on_repoRefresh_clicked
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 989, in setup_yum
    if self._runBackground( self.yumexbase.setup, rload ):
  File "/usr/share/yumex/yumexmain.py", line 1045, in _runBackground
    raise self.backgroundThread.exception
ValueError: Error parsing 'localhost:8080': URL must be http, ftp or https not "localhost"

Local variables in innermost frame:
runfunc: <bound method yumexBase.setup of <yumex.yumexBase.yumexBase object at 0x19fb3750>>
args: (False,)
self: <__main__.YumexMainApplication instance at 0x19fa4b90>

*end dump


Version-Release number of selected component (if applicable):
yumex-1.2.2-1.0

How reproducible:
Always


Steps to Reproduce:
1. insert the proxy url
2. update 
3. watch it blow

Actual Results:
crash.

Expected Results:
use the given proxy (? maybe have a default protocol setting ?).

Additional info:
If the DNS resolver would have worked right instead of using 1.0.0.0 on IPv6 responses, I wouldn't have used a proxy.
Tell the DNS resolver guys to do you a favour, and resove using IPv4 as default, or at least provide a system-wide (effective!) configuration to disable IPv6.
It was easier to setup a proxy then deal with the IPv6.
And as you see, it wasn't too easy... :)

Comment 1 Tim Lauridsen 2007-05-01 09:04:31 UTC

*** This bug has been marked as a duplicate of 229523 ***


Note You need to log in before you can comment on or make changes to this bug.