Bug 237792 - working /etc/yum/yum-updatesd.conf file
Summary: working /etc/yum/yum-updatesd.conf file
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL: N/A
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-25 14:10 UTC by Keith Roberts
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 15:19:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Keith Roberts 2007-04-25 14:10:46 UTC
The default config file for yum-updatesd does not send out any email messages  
at all, due to 2 missing variables in the config file.

Here is a working version for you to tweak for your system. This is an issue 
that really needs to be fixed - ie the email_to & email_from properties need 
to be added to the default config file. Then users will be able to see what 
values they need to set for their system, to receive the email notifications 
for available upgrades.

[main]

# how often to check for new updates (in seconds)
run_interval = 3600
# how often to allow checking on request (in seconds)
updaterefresh = 600

# ------------------------------------------------------

# how to send notifications (valid: dbus, email, syslog)
emit_via = email

# who to send the email notifications to
email_to = keith@karsites.localdomain

# who sent the notifications
email_from = root@karsites.localdomain

# ------------------------------------------------------

# automatically install updates
do_update = no
# automatically download updates
do_download = no
# automatically download deps of updates
do_download_deps = no

# ------------------------------------------------------
# eof

Even with this working config file, yum-updatesd only seems to run 
occasionally. I'm aware of the bug reports in general about yum-updatesd.

I'm considering stopping and restarting yum-updatesd with a root cron job, to 
see if that will force yum-updatesd to check for updates.

Comment 1 Jeremy Katz 2007-04-25 15:19:13 UTC
The default is to send to root@localhost from root@localhost.  The options for
sending elsewhere are all documented in the man page.


Note You need to log in before you can comment on or make changes to this bug.