This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 237793 - font color problem
font color problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
N/A
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 10:22 EDT by Keith Roberts
Modified: 2013-07-02 19:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 07:43:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Roberts 2007-04-25 10:22:17 EDT
I'm using mc-4.6.1a-35.fc6 on three different
machines. There is a problem with the directory colors
showing the same as ordinary files, and not bold white.

When I highlight a file with the insert key, it shows up as
a rusty brown color, not yellow. The same applies to the
yellow highlighting in the dialogues.

Any ideas why this is happening please, and what to do to
fix the colors so they work correctly?

Other Linux distros mc packages worked OK on these
platforms, including SuSE, Debian, and Kubuntu.

How reproducible: Always

Steps to Reproduce:
1. Start the CLI version of mc - (not the X11 version as that works OK)
Comment 1 Jindrich Novy 2007-06-18 07:43:44 EDT
The problem is that the default font for console font doesn't support "bold"
extension and uses wider range of characters (512) instead. For that reason the
font support only 8 colors. You need a font that support more colors. To do this
type, say:

setfont lat1-16

This font supports 16 colors.
Comment 2 Keith Roberts 2007-09-17 12:41:52 EDT
Thanks for that Jindrich. I have added the setfont lat1-16 command to my
/etc/profile file, and now whenever I log in as root or normal user under the
CLI and start mc,the font problem is resolved. (Would it not be better to
support a 16 color font as standard if FC CLI mode?)

However, when running KDE and logging into a root shell, I get the following
message:

Password:
putfont: PIO_FONT: Invalid argument
[root@fc6-localhost ~]# qps

This doesn't happen as a normal user. There does not seem to be any adverse
effects either after getting this message. mc font colors still work ok.
Comment 3 Keith Roberts 2007-10-09 17:53:24 EDT
Apparently, according to Ignacio Vazquez-Abrams from the Fedora Core
<fedora-test-list@redhat.com>

"The correct fix is to change the console font that is being used in the
appropriate configuration file (which is /etc/sysconfig/i18n, for those
not paying attention)."

So I changed that to:

SYSFONT="lat1-16"

and removed the patch at the end of /etc/profile.

It works fine now, Maybe this could be the default font for Fedora 8 please?



Note You need to log in before you can comment on or make changes to this bug.