This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 237814 - Wrong init script
Wrong init script
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bootparamd (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Dvoracek
:
Depends On:
Blocks: 237789 237822 237824
  Show dependency treegraph
 
Reported: 2007-04-25 11:10 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 16:29:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Porposed patch (717 bytes, patch)
2007-05-17 03:46 EDT, Ondrej Dvoracek
no flags Details | Diff

  None (edit)
Description Michal Marciniszyn 2007-04-25 11:10:45 EDT
Description of problem:
Following code returns 0 when the script is run even when the service is not
started.
[ -f /etc/bootparams ] || exit 0

# Check that networking is up.
if [ ${NETWORKING} = "no" ]
then
        exit 0
fi
It also forbids the correct invocation of the status parameter. Also the return
code for unknown request to the script is not 1 but 3...


Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service bootparamd status
3. echo $?
  
Actual results:
0

Expected results:
status of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Ondrej Dvoracek 2007-05-17 03:46:20 EDT
Created attachment 154895 [details]
Porposed patch

Please, try this patch and let me know.
Comment 2 RHEL Product and Program Management 2007-06-05 16:29:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.

Note You need to log in before you can comment on or make changes to this bug.