Bug 237827 - Wrong init script
Summary: Wrong init script
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cachefilesd   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: David Howells
QA Contact:
URL:
Whiteboard: RHEL5.1NAK
Keywords:
Depends On:
Blocks: 237789 237828 237829
TreeView+ depends on / blocked
 
Reported: 2007-04-25 15:30 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:02 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0412
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 16:54:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Further initscript fixes (work around status() and wait for stop completion) (804 bytes, patch)
2008-04-04 13:52 UTC, David Howells
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0412 normal SHIPPED_LIVE cachefilesd bug fix update 2008-05-19 22:31:01 UTC

Description Michal Marciniszyn 2007-04-25 15:30:56 UTC
Description of problem:
Following code
if [ ! -f /etc/sysconfig/network ]; then
    exit 0
fi
. /etc/sysconfig/network

# Check that networking is up.
[ "${NETWORKING}" = "no" ] && exit 0
returns exit code 0 even if the service is not runnung. There are several other
constructions in the script and incorrect return codes.


Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service chachefilesd start/status
3. echo $?
  
Actual results:
0

Expected results:
non-zero exit code/status of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

Comment 1 RHEL Product and Program Management 2007-05-10 19:10:16 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 RHEL Product and Program Management 2007-10-19 20:29:31 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 Ondrej Hudlicky 2008-04-04 09:25:20 UTC
Changing status to ASSIGNED
Iniscripts are still broken: condrestart only stop the service 
Some fixing in specfile is also recommended. More info in errata. 

Comment 10 David Howells 2008-04-04 13:40:54 UTC
The condrestart problem is due to a bug in /etc/init.d/functions (bug 440658).  
This can be worked around by making condrestart invoke stop and start directly 
rather than by invoking restart and letting that then invoke stop and start.  

The problem is that the status() function uses pidof, with exclusions for 
itself and its parent process, but doesn't give exclusions for its 
grandparent, great-grandparent, etc., but the cachefilesd recurses more then 
once.  This means there are several scripts all called 'cachefilesd' in 
addition to the actual caching daemon all running at the same time.

There's also a problem whereby the stop function does not wait for the 
cachefilesd daemon to complete (which might take some time).  This can be 
fixed by putting in a short wait.

Comment 11 David Howells 2008-04-04 13:52:43 UTC
Created attachment 300431 [details]
Further initscript fixes (work around status() and wait for stop completion)

Comment 16 errata-xmlrpc 2008-05-21 16:54:46 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0412.html



Note You need to log in before you can comment on or make changes to this bug.