Bug 237836 - .spec file uses undefined macro
.spec file uses undefined macro
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: uudeview (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 11:48 EDT by Florian La Roche
Modified: 2008-05-05 08:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 08:41:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-04-25 11:48:10 EDT
Description of problem:

[laroche@porky i386]$ rpm -qp --provides uulib-devel-0.5.20-11.i386.rpm
uulib = {version}-11
uulib-devel = 0.5.20-11
[laroche@porky i386]$



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2007-04-25 12:14:23 EDT
While you're at it, since it (only) contains static libs, should be named 
*-static:
http://fedoraproject.org/wiki/Packaging/Guidelines?highlight=%28Packaging%29#head-82d97fc4a3421310f4e2971180e4165965b65662
Comment 2 Patrice Dumas 2008-04-10 06:38:37 EDT
I think that it should better be called uulib-devel and have a
Provides: uulib-static = %{version}-%{release}

It is how it is done in most cases. Since the devel is Provided it is
not a must, but I think that it should be done that way for 
consistency.
Comment 3 Adrian Reber 2008-05-05 08:41:02 EDT
Closing it again. uulib-devel/uulib-static has been fixed with a patch from
Patrice. See #443649.

Note You need to log in before you can comment on or make changes to this bug.