Bug 237851 - Installation of xen guest fail on using FC6
Installation of xen guest fail on using FC6
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
Depends On:
  Show dependency treegraph
Reported: 2007-04-25 14:20 EDT by Steve Dickson
Modified: 2009-12-14 15:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 15:32:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screen Shot of the error (7.98 KB, image/png)
2007-04-25 14:20 EDT, Steve Dickson
no flags Details
Screen shot of test2 hang (24.41 KB, image/png)
2007-05-22 16:56 EDT, Steve Dickson
no flags Details
screen shot of F-7 Test4 Failure (23.32 KB, image/png)
2007-05-23 10:19 EDT, Steve Dickson
no flags Details

  None (edit)
Description Steve Dickson 2007-04-25 14:20:04 EDT
Description of problem:
Using an uptodate FC6, runing the 2.6.19-1.2911.6.5.fc6xen
kernel, the installation of a xen guest using the 
virt-managner (0.2.6) fails with an
'exec of anaconda failed: Access a corrupted share library'
error. See attachement 
Version-Release number of selected component (if applicable):

How reproducible:
all the time

Steps to Reproduce:
1. use virt-manager to create a xen guest
2. point the install Media URL at 
3. Use a "Normal Disk Partition"
4. set "VM Startup Memory to 336
5. Click Finish to get things rolling
6. Take all the default until anaconda crashes.
Actual results:

Expected results:

Additional info:
Comment 1 Steve Dickson 2007-04-25 14:20:04 EDT
Created attachment 153435 [details]
Screen Shot of the error
Comment 4 Eduardo Habkost 2007-05-16 12:21:07 EDT
I was going to report a different problem, when I was trying to install FC7 
under FC6 Xen. But on my case, nothing was being shown in the virtual machine 
display or the VM serial console. Not even the loader messages.

I have tried previous Test versions of FC7 as install media, and FC7-Test2 
have worked for me.

I will try to reproduce the problem here. I hope the loader will run, today, 
otherwise I will have to debug the loader problem before I get the "Accessing 
a corrupted shared library" error.  :)
Comment 5 Eduardo Habkost 2007-05-18 10:40:30 EDT
I have not been able to reproduce exactly your problem, but the problem I am 
having here may be related:

- Using virt-install from rawhide-20070502 (I don't have a more recent FC7 
installation media available yet) doesn't work. Nothing is shown, not even 
the "running /sbin/loader" messages in the console
- Using virt-install from FC7-Test2 works (the installer dialogs are shown)
- Using initrd.img from rawhide-20070502 and kernel from FC7-Test2 works
- Using initrd.img from FC7-Test2 and kernel from rawhide-20070502 doesn't 

So, it seems that the kernel has a problem, or the installer doesn't like the 
newer kernel. I am investigating what could be wrong with the newer kernel.
Comment 6 Eduardo Habkost 2007-05-18 11:03:19 EDT
Just to check if the problem I am having can really be related with your 
problem, could you check what is the behaviour when using FC7-Test2 and 
FC7-Test3 as installation media?

If it shows the same behaviour I have here (it doesn't work on Test3 but works 
on Test2), then the cause of the problem I am seeing here may be the same.

If the results are different, then probably we have two different bugs to 
investigate and solve.
Comment 7 Steve Dickson 2007-05-22 16:56:02 EDT
Created attachment 155201 [details]
Screen shot of test2 hang

Test2 hung much earlier that Test3
Comment 8 Steve Dickson 2007-05-23 10:19:36 EDT
Created attachment 155243 [details]
screen shot of F-7 Test4 Failure

Well test4 is failing an a different place... not
sure if  that is a step ahead or back... but
it is different...
Comment 9 Stephen Tweedie 2007-05-23 11:33:55 EDT
Steve, were you installing fully virt or paravirt?  Can you reproduce off other
install media, just to validate that it's not something like a corrupt mirror?
Comment 10 Daniel Berrange 2007-05-23 11:39:37 EDT
The F7 test4 kernels still have all the horrible data corruption bugs we
recently fixed. Though we mostly saw them on Dom0, we never ruled out the
possiblily of them impacting DomU too. I'd not bother trying any of the testN
releases of F7 and go straight to very latest rawhide which is very nearly GA now.
Comment 11 Red Hat Bugzilla 2007-07-24 21:40:35 EDT
change QA contact
Comment 12 Steve Dickson 2007-07-26 10:43:00 EDT
paravirt to the installing question.... 

So would install f7 and using KVM be a better option at this point?
I do have correct hardware... 
Comment 13 Brian Stein 2007-07-26 13:22:31 EDT
steved - has anyone stopped by to take a look at your machine / use it for testing?
Comment 14 Steve Dickson 2007-07-27 08:31:03 EDT
No... but I was thinking of moving on to F7, but I would be
more than willing to wait if that would help this out....

Question: Should I be able to install a F7 Client with the
latest FC6 xen kernel?
Comment 15 Eduardo Habkost 2007-07-27 17:39:16 EDT
(In reply to comment #14)
> Question: Should I be able to install a F7 Client with the
> latest FC6 xen kernel?

Yes, you are. Not being able to install it under FC6 is a bug on either F7 or 
FC6. However I don't know how much time we will take to find the cause and fix 
Comment 16 Bug Zapper 2008-04-04 03:06:32 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 17 Bug Zapper 2008-05-06 15:32:12 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.