Bug 237951 - anthy-8700b-1.fc6.src.rpm after building it appears: anthy-8700b-1..rpm
anthy-8700b-1.fc6.src.rpm after building it appears: anthy-8700b-1..rpm
Product: Fedora
Classification: Fedora
Component: anthy (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Depends On:
  Show dependency treegraph
Reported: 2007-04-26 07:26 EDT by Danilo Marcucci
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-30 21:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Danilo Marcucci 2007-04-26 07:26:59 EDT
Description of problem:
After rebuild the package anthy-8700b-1.fc6.src.rpm with this string:
#rpmbuild --rebuild --target i686 anthy-8700b-1.fc6.src.rpm
it appears therefore: anthy-8700b-1..rpm in /usr/src/redhat/RPMS

Version-Release number of selected component (if applicable):

How reproducible:
Rebuilding the package

Steps to Reproduce:
#rpmbuild --rebuild --target i686 anthy-8700b-1.fc6.src.rpm
ls /usr/src/redhat/RPMS
Actual results:
Builded bat without achitecture i686 only anthy-8700b-1..rpm

Expected results:

Additional info:
Comment 1 Akira TAGOH 2007-04-26 19:23:57 EDT
I'm sorry, it works for me on fc6 box. which distro are you building it on? and
how about rpm version? it's more likely a "rpm" bug. I don't think there are
anything I can do help on this package.
Comment 2 Danilo Marcucci 2007-04-27 03:34:10 EDT
I have it on Fedora Core 6
# uname -a
Linux builder.mynet.it 2.6.20-1.2933.fc6 #1 SMP Mon Mar 19 11:38:26 EDT 2007
i686 i686 i386 GNU/Linux

and this version of rpm
# rpm --version
RPM version 4.4.2

Comment 3 Akira TAGOH 2007-04-27 06:01:20 EDT
I meant EVR.

% rpm -q rpm

I'm wondering if you can see the similar issue on other package building too.
Comment 4 Danilo Marcucci 2007-04-27 06:41:04 EDT
I have the same too
# rpm -q rpm

I'm secure of I have installing Fedora Core 6 downloaded from this mirror

Do you have anther idea?
Comment 5 Akira TAGOH 2007-04-28 08:36:32 EDT
I haven't yet heard anything from you for another package build though, if you
can see this issue on only building anthy, it may be more relevant to the
package. well, it still looks even weird to me though. otherwise I'll reassign
this to rpm, since it may be not anthy-package-specific.

Also it may be a good idea to attach the build log.
Comment 6 Danilo Marcucci 2007-04-28 17:55:02 EDT
I have building this package with this option on command line: --define "dist
.fc6" --define "fedora 6" because there are other package that haven't in
package rebuilded the relase distro "fc6". I have used this option also anthy
package and the result is successiful.
Full command line:
#rpmbuild --define "dist .fc6" --define "fedora 6" --rebuild i686
Result the package is compiled correctly anthy-8700b-1.fc6.i686.rpm.
I think that are other problems that not depend from anthy package, but my be
depende of the rpm package.
For me you can closed this bug with "not a bug".
Comment 7 Akira TAGOH 2007-04-30 21:43:45 EDT
Sure. closing.

Note You need to log in before you can comment on or make changes to this bug.