Bug 237986 - Tomboy eats CPU as session startup program
Tomboy eats CPU as session startup program
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tomboy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 08:54 EDT by Paul W. Frields
Modified: 2013-01-09 23:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 20:20:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2007-04-26 08:54:59 EDT
Description of problem:
I have Tomboy set as a startup program in my GNOME session preferences.  It
worked well in FC6.  However, now that I am using Rawhide, usually the trayicon
does not appear, and Tomboy begins eating CPU time.  Usually I have to kill and
restart it from a terminal for it to work properly.

Version-Release number of selected component (if applicable):
0.6.1-1.fc7

How reproducible:
Almost every time.

Steps to Reproduce:
1. Set Tomboy as a GNOME session startup program (command "tomboy," no extra
options)
2. Login to GNOME normally.
  
Actual results:
CPU time spikes in Tomboy

Expected results:
Nice Tomboy, good Tomboy.

Additional info:
The vast majority of Tomboy's time seems to be spent reading and writing from a
socket (usually fd #12 here), as shown in strace.  If I attach to the process
with gdb, and have tomboy-debuginfo installed, how can I give you more useful
information?
Comment 1 Jesse Keating 2007-04-28 17:22:43 EDT
I'm seeing this too, however I was reluctant to report it since this is a
machine that started as FC5 Test something, and upgraded overtime to rawhide. 
If I kill tomboy and start it again, everything is fine.
Comment 2 Paul W. Frields 2007-04-28 19:09:04 EDT
Well, thank goodness someone else is seeing this.  This machine is a straight
install, no upgrade, so it's probably not you.  Same here as far as a temporary
remedy.
Comment 3 Paul Dickson 2007-04-28 19:45:34 EDT
I have been seeing this for about a month or more.  It's led me to avoid tomboy
by not restarting once I kill it.  It only happens at Gnome session startup.

My system has stayed pretty-much current with rawhide since FC4-test2
Comment 4 Paul W. Frields 2007-05-01 19:01:30 EDT
I think this was a pango problem.  It "solved itself" after today's update from
rawhide, which included pango-1.16.4-1.fc7.  Since that was the only thing
updated that seemed like it was possibly tied up with tomboy (thanks, ldd), I
backed down to 1.16.2-1.fc7, and the problem recurred.  If someone else can
confirm the same behavior, I'll reassign this and then close it.
Comment 5 Paul W. Frields 2007-05-02 07:47:31 EDT
Spoke to soon.  This morning after another reboot the same problem occurred.
Comment 6 Paul W. Frields 2007-06-18 14:45:46 EDT
I think I truly know what causes the problem now, so I can only tell you how to
relieve it.  Brian, if you could relate this upstream I guess that would help. 
My ~/.tomboy/Plugins/ folder contained a file "DefaultPlugins.desktop" which
looked like this:

[Desktop Entry]
Version=@VERSION@
Encoding=UTF-8
Type=Link
URL=file:///usr/lib/tomboy/Plugins
Icon=gnome-fs-directory
X-GNOME-DocPath=
Terminal=false
Name=Default Plugins
Comment=Directory containing system-installed Plugins

If I remove the Plugins/ directory and turned tomboy back on in my automatic
session start program listing, everything works great again.  The newly-created
DefaultPlugins.desktop file looks somewhat different.  (Some entries may be
garbled if you don't have extra language fonts installed as I do.)  In
particular, the "Version" field is gone:

[Desktop Entry]
Encoding=UTF-8
Type=Link
URL=file:///usr/lib/tomboy/Plugins
Icon=gnome-fs-directory
X-GNOME-DocPath=
Terminal=false
Name=Default Plugins
Name[bg]=Стандартни приставки
Name[ja]=デフォルトのプラグイン
Name[nl]=Standaardplugins
Name[pt]=Plugins Por Omissão
Name[ru]=Стандартные расширения
Name[zh_CN]=默认插件
Comment=Directory containing system-installed Plugins
Comment[en_GB]=Directory containing system-installed Plugins
Comment[sv]=Katalog som innehåller de insticksmoduler som är installerade på
systemet
Comment 7 Matthias Clasen 2007-10-19 15:37:18 EDT
We ship tomboy as part of the default panel configuration; do you still see
issues with it in current rawhide ?
Comment 8 Paul W. Frields 2007-10-20 20:20:47 EDT
Seems fixed in all configurations, both the default user panel and as a session
startup program (swallowed in the notification area) in current Rawhide.
Comment 9 Paul W. Frields 2007-10-22 17:11:10 EDT
Apparently I didn't test the configuration that involves rebooting and using
Tomboy as a session startup program.  When I do this, the CPU problem manifests
again.  Reopening.
Comment 10 Bug Zapper 2008-04-03 20:17:01 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 11 Jesse Keating 2008-04-03 20:20:32 EDT
I have not seen this in a long time, I'm going to close it.

Note You need to log in before you can comment on or make changes to this bug.