Bug 238005 - Removable USB drive mounted with root ownership
Removable USB drive mounted with root ownership
Status: CLOSED DUPLICATE of bug 234716
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 10:48 EDT by Steve Fox
Modified: 2013-03-05 22:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 10:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2007-04-26 10:48:20 EDT
Description of problem:

My SanDisk Cruzer Micro 2.0GB removable USB drive is not writable by my non-root
user ID after gnome-volume-manager mounts it and Nautilus opens a new window for
it. The /media/disk directory is owned by root instead of my userid. This is a
regression from my FC6 machine where this works flawlessly.

Version-Release number of selected component (if applicable):

gnome-volume-manager-2.17.0-5.fc7
hal-0.5.9-5.fc7
nautilus-2.18.1-2.fc7
ConsoleKit-0.2.1-2.fc7

How reproducible:

Every time.

Steps to Reproduce:
1. Copy files to my USB drive on FC6 and unmount drive.
2. Bring USB drive to rawhide machine and plug in.
3. Nautilus opens a window, but I cannot write to or delete files from it.

Actual results:

Nautilus prints a warning that I do not have appropriate ownership and refuses
to write.

Expected results:

The drive (/media/disk) should be owned by my userid.

Additional info:

When I unmount the drive using Nautilus, I do not get the 'You may safely remove
this device' message that I get on FC6. That message gives me warm, fuzzy feelings.
Comment 1 David Zeuthen 2007-04-26 10:59:50 EDT

*** This bug has been marked as a duplicate of 234716 ***

Note You need to log in before you can comment on or make changes to this bug.