Bug 23801 - Attempted and failed Redhat 7 install on duel processor PowerEdge 4400 w/ RAID 5 (Perc SC)
Attempted and failed Redhat 7 install on duel processor PowerEdge 4400 w/ RAI...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-11 11:41 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 15:48:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System specification (24.94 KB, text/html)
2001-01-11 12:05 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-01-11 11:41:37 EST
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/usr/lib/anaconda/todo.py", line 1476, in doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (6, 'Device not configured')

Local variables in innermost frame:
size: 10241406
fsystem: ext2
self: <fstab.NewtFstab instance at 8226138>
msg: Device not configured
doFormat: 1
errno: 6
device: sda19
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Need Real Name 2001-01-11 11:50:00 EST
Btw, this error came up after an initial error:  The installation is proceeding 
through the formatting of the partitions I have created.  It gets to a certain 
partition and then hangs.  So I reboot and try to install in text mode, hoping 
to shake things up a little.  I get to the same point where things hang, and 
then I press the magical "Enter" button.  The jogs the hang and the formatting 
proceeds.  After I format some more partitions, I get to the swap partition and 
immediately get the error:
"Error creating swap on defvice sda21"
and then:
"Error mounting sda19: Device not configured."

If I'm guessing, the first error happened, causing the install to puke.  The 
program then tried to dump core or write to the tmp/install.log (or whatever 
it's called) and then realized that /tmp hadn't been formatted yet, or if it 
had, it was all @#$%! up, thus causing the second error message.  I believe the 
dump listed was from the secondary error and not the originating error.  

In total I observed three anomalies:
1.  Formatting /q/atheneaum/home/atheneaum6  hangs.
2.  Creating a swap file fails.
3.  Accessing sda19 fails.

Comment 2 Michael Fulbright 2001-01-11 11:53:54 EST
What is the exact hardware specs of the machine you are installing?
Comment 3 Need Real Name 2001-01-11 12:05:33 EST
Created attachment 7425 [details]
System specification
Comment 4 Need Real Name 2001-01-11 12:16:13 EST
PS - Dell was able to get a copy of Redhat installed.  But I didn't like
their "no reasonable partitions" policy.  Plus, I wanted to reconfigure the RAID
setup so that I had 1 (of 6) hot swappable backup disks in the RAID array.

After I made this change through the PERC BIOS I attempted to reinstall Redhat.
Comment 5 Need Real Name 2001-01-12 15:48:02 EST
For the record, I got Linux to install.  All I had to do was change all my 
18Gb partitions to 38Gb partitions.  

I'm guessing there is some implicit limit on the number of partitions that will 
format OR that there is some bug concerning the size of the partition name OR a 
little bit of both.  Most of my partitions were of the form:

/q/atheneaum/home/atheneaum1 (Through 7)
/q/atheneaum/proj/atheneaum1 (Through 6)
/tmp
/var
/
/usr
/boot
swap

All told that's about 20.  Is that too many?  

Of course I'm not very happy with my new partitioning because now it's a lot 
harder to backup based on partitions.  Oh well, maybe next time.

Hope this helps. 
-David
Comment 6 Michael Fulbright 2001-01-26 18:34:36 EST
I think the limit imposed by the linux kernel is 16 partitions per SCSI drive.
Comment 7 Need Real Name 2001-01-26 19:27:13 EST
Well, that would make a lot of sense since I had 7 home 6 proj and 5 other 
partiions.  This sums to 18, but it started at 5, so make 23.  It dies on '21', 
which if you subtrace the 5 is 16.  Viola.  Normally I look for bugs around 
powers of 2 as system limit bugs but the starting at 5 threw me.
Thanks, 
d

Note You need to log in before you can comment on or make changes to this bug.