Bug 238012 - Possible NULL pointrer dereference with updated X.Org
Summary: Possible NULL pointrer dereference with updated X.Org
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rdesktop   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: David Zeuthen
QA Contact:
URL: http://rdesktop.cvs.sourceforge.net/r...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-26 15:04 UTC by Lubomir Kundrak
Modified: 2013-03-06 03:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 21:40:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lubomir Kundrak 2007-04-26 15:04:09 UTC
Description a problem:

The recent update of libx11 package reportedly broke some packages
incorrectly using XCreateImage(), whose behavior was slightly changed
to return NULL in case it was passwd wrong parameters. This could lead
to a NULL pointer dereference crash in programs that did not check
the return value properly. Rdesktop is reportedly one of those.

http://rdesktop.cvs.sourceforge.net/rdesktop/rdesktop/xwin.c?view=log

Comment 2 RHEL Product and Program Management 2007-04-26 15:17:28 UTC
Since Keyword Regression exists, this is a blocker,
not an exception.  Cleared exception flag.
Set blocker flag."


Note You need to log in before you can comment on or make changes to this bug.