Bug 238038 - Syncronize Nokia E61i with a Fedora Core 6 desktop via Bluetooth
Syncronize Nokia E61i with a Fedora Core 6 desktop via Bluetooth
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnokii (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 12:55 EDT by Răzvan Sandu
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 14:13:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of sdptool browse <MAC> (4.30 KB, text/plain)
2007-04-26 12:58 EDT, Răzvan Sandu
no flags Details
Output of hcitool info <MAC> (528 bytes, text/plain)
2007-04-26 13:08 EDT, Răzvan Sandu
no flags Details
The /etc/gnokiirc file I use (7.04 KB, text/plain)
2007-04-26 13:10 EDT, Răzvan Sandu
no flags Details

  None (edit)
Description Răzvan Sandu 2007-04-26 12:55:10 EDT
Description of problem:

Hello,

Please provide a method to syncronize a Nokia E61i phone with a Fedora Core
desktop, via a Bluetooth connection.

Phone is Nokia E61i (smatphone, Symbian-based):
http://europe.nokia.com/A4344018

Bluetooth dongle is Belkin F8T012 (FCC ID K7SF8T012):
http://web.belkin.com/support/download/download.asp?category=206&lang=1&mode

Computer runs stock FC6 + updates as April 25, 2007.

When I insert the Bluetooth dongle, it is recognised by Fedora and I can do
Bluetooth pairing with the phone.

However, doing "gnokii --identify" locks up indefinitely.


Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2944.fc6
gnokii-0.6.14-2.fc6
xgnokii-0.6.14-2.fc6
bluez-utils-3.9-1.fc7 (official version from Fedora repository)

How reproducible:
Always.

  
Actual results:
gnokii and xgnokii seems to lock up when trying to establish a connection with
the phone. No syncronization is possible.

There is no detailed documentation available, with a step-by-step procedure.


Expected results:
It should be possible to syncronize the phone with the Linux desktop via gnokii.
Documentation for final users should be available.


Additional info:
Please see attached files containing output from various utilities.
Comment 1 Răzvan Sandu 2007-04-26 12:58:22 EDT
Created attachment 153530 [details]
Output of sdptool browse <MAC>
Comment 2 Răzvan Sandu 2007-04-26 13:08:40 EDT
Created attachment 153531 [details]
Output of hcitool info <MAC>
Comment 3 Răzvan Sandu 2007-04-26 13:10:55 EDT
Created attachment 153532 [details]
The /etc/gnokiirc file I use
Comment 4 Linus Walleij 2007-04-26 14:34:58 EDT
Hm, it's another one of those...

Thing is it sort of work for me, and I don't have neither
of these two devices :-/ kinda hard to test without the
device in question.

I am afraid the best way to get any feedback is in upstream
(http://www.gnokii.org/) mailinglist.
Comment 5 Bastien Nocera 2007-07-10 11:43:47 EDT
That's not needed:
rfcomm_channel = 14
and probably wrong.

Furthermore, you probably want to use the gnapplet driver, and the related
applet on your phone instead of the "series60" driver. But it should still work.

Could you please attach the full output of "gnokii --identify" when connecting
to the phone?
Comment 6 Bastien Nocera 2007-08-23 11:33:00 EDT
Pawel Kot, the gnokii upstream maintainer tells me that gnokii does not support
Symbian Series60 3rd Edition phones (this means most Nokia E-series and N-series).

So closing as UPSTREAM, there's no upstream support for it.
Comment 7 Răzvan Sandu 2007-09-28 13:48:49 EDT
Hello,


And thanks for your answer.


Unfortunately, maybe I've put this in a wrong way:

It is not about some program (gnokii) supporting or not one particular phone.
Maybe it's not even a gnokii "bug". It's more about Fedora (as a whole OS) than
about gnokii.

Mobile phones are an everyday part of our lives and on any major OS we need a
robust solution to access this hardware, to syncronize that with our PCs. Fedora
is no exception.

I've put this "bug" on gnokii because gnokii seems to be the only piece of
software included in the distro which deals with mobile phones.

IMHO, having full support for old phone models that are no longer on the market
seems to be a waste of time and work. It might be interesting from the
programmer's point of view, as a hacking & reverse engineering exercise, but
it's absolutely unuseful for the final user.

Nokia N-Series and E-series are very common today and we desperately need a way
to communicate with the phone we have in our own pocket - at least for competing
with Microsoft Windows OS. Motorola RAZRs, Sony Ericsson, LG, HTC are in the
same trouble.

Can we kindly ask the distribution maintainer to identify and include in Fedora
some package that supports the actual phones we need, at least at a basic level
? IMHO, functionality being pretty much the same between phone models, we only
need a basic, common, unitary text/GUI interface and plugins/APIs for each
hardware piece we support. It's not about replicating on Linux the whole fuss of
Motorola Phone Tools or Nokia PC Suite, which are obscure and unstable applications.

I will reopen this bug, not for the gnokii/xgnokii packages, but for the distro
maintainer as a whole. Please reassign it to whom it may concern.

Many thanks,
Răzvan
Comment 8 Bastien Nocera 2007-09-28 14:13:40 EDT
That's all good and well, but you should take your feature request to the fedora
devel mailing-list where you might be able to get some traction for this project.

But unless you are willing to get involved, I don't see this project as
happening. You might get lucky if it matches the targets of the developers that
are willing to implement this.
Comment 9 Linus Walleij 2007-09-28 14:33:16 EDT
(In reply to comment #7)

> Nokia N-Series and E-series are very common today and we desperately need a way
> to communicate with the phone we have in our own pocket -

If you bought it from Nokia, then why not talk to Nokia about the
problem? If they put the product on the market and you bought it, you
are entitled to their support of your needs.

> at least for competing
> with Microsoft Windows OS. Motorola RAZRs, Sony Ericsson, LG, HTC are in the
> same trouble.

Most of these actually work very well with latest gnokii due to Bastiens 
tireless work on the AT-command parser in gnokii.

> Can we kindly ask the distribution maintainer to identify and include in Fedora
> some package that supports the actual phones we need, at least at a basic level
> ?

I think it is better to ask Nokia and [phone brand here] to cooperate
with gnokii authors.

> IMHO, functionality being pretty much the same between phone models, we only
> need a basic, common, unitary text/GUI interface and plugins/APIs for each
> hardware piece we support. It's not about replicating on Linux the whole fuss of
> Motorola Phone Tools or Nokia PC Suite, which are obscure and unstable
applications.

Yes that is the idea about gnokii and gnome-phone-manager I think.

Note You need to log in before you can comment on or make changes to this bug.