Bug 238040 - toshiba P2000 can't resume from suspend (to ram)
toshiba P2000 can't resume from suspend (to ram)
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-04-26 13:12 EDT by cje
Modified: 2013-03-05 22:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-24 10:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch for 20-video-quirk-pm-toshiba.fdi (852 bytes, patch)
2007-04-26 13:12 EDT, cje
no flags Details | Diff

  None (edit)
Description cje 2007-04-26 13:12:06 EDT
Description of problem:
i get a yellow "Linu" when i try to resume from suspend (to ram) on my toshiba
portege P2000.  

Version-Release number of selected component (if applicable):

Additional info:
following this post: http://kernelslacker.livejournal.com/77250.html i tried
editing the
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-toshiba.fdi file.
 success!  i'll attach a patch.  i don't know for sure if both 'merge' lines are
really needed but it seems likely looking at the rest of the file.
Comment 1 cje 2007-04-26 13:12:06 EDT
Created attachment 153533 [details]
patch for 20-video-quirk-pm-toshiba.fdi
Comment 2 David Zeuthen 2007-04-30 15:22:35 EDT
Committed, thanks!


I'll make sure we'll have a new hal-info release with this before Fedora 7.
Comment 3 cje 2007-05-09 06:46:08 EDT
hello.  really sorry but it appears i've been a bit too quick to say this is
working.  it worked the first time i suspended but since then it's been failing
on the second consecutive resume every time and also failing on the occasional
first resume.  with the same yellow "Linu".

i'm working through all the quirks options trying to figure out what works best
but it's going to take a while because a) i can't find _any_ useful information
about those quirks and b) the problems are rather intermittent.

there's no harm in my previous patch going upstream as it does improve the
situation slightly but i'll update it here once i find a stable setup.  i'm sure
it's possible cos i'm pretty sure it was working fine in F7T1.

any chance anyone's got a document somewhere about the quirks modes?  in
particular i'm wondering if (for example) "s3_bios" is an undesirable catch-all
(as in, it will always work but it would be better not to use it) or not.

Comment 4 cje 2007-05-17 08:27:29 EDT
looking at this:
now :-)
Comment 5 cje 2007-07-15 14:50:03 EDT
i've tried everything on the quirks page, including the magic debugging trick
saving data in the RTC.  still nothing.

occasionally you get one successful resume but nothing consistent.

i'm almost certain this was working perfectly in either F7T1 or F7T2.  is there
any way of figuring out what the default suspend/resume setup was back then and
finding a way to reproduce that?  pretty please?  it was really nice when it worked.
Comment 6 cje 2007-10-16 06:40:36 EDT
exciting new update for F8T3, 2.6.23-6.fc8:
it worked once.
then got stuck on the second resume.
after that it's gone back to getting stuck on every resume.
it's not stuck with a yellow "Linu" message though - now it's an orange "Ũ3MY".
 pretty sure i saw that on the screen briefly the one time it resumed
successfully too.
hope that helps.
Comment 7 cje 2007-10-16 06:46:52 EDT
re-assigned to kernel - it was only hal-info because i thought i'd fixed it by
using existing quirks.
Comment 8 David Zeuthen 2007-10-16 10:39:23 EDT
(please remember to reassign the bug owner too)
Comment 9 cje 2008-03-14 13:50:48 EDT
it's looking like this got fixed in the jump to 2.6.24.

with the current enabled quirks the system comes back up but the screen goes
really weird in a hardware-looking way ... it gradually goes white.

with all quirks switched off ... success!  i've done half a dozen suspend-resume
cycles and a reboot too.  all working.  i'm so happy!!  seriously.

so i think we need to remove the mention of P2000 from the toshiba quirks file
Comment 10 Bug Zapper 2008-05-13 22:48:40 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 11 cje 2008-06-12 06:14:57 EDT
back to hal-info to get the P2000 reference removed again.  i've guessed the
assignee.  sorry if it's wrong.

is it worth mentioning (in a comment in the file?) that it only really works
with 2.6.24 and above?  is there some way to disable suspend-to-ram for P2000
running earlier kernels?
Comment 12 cje 2009-03-24 10:33:44 EDT
i'm closing this because i'll submit a patch upstream once i've done some more tests.  it's looking like it works with 'quirk-none' in F10.

Note You need to log in before you can comment on or make changes to this bug.