Bug 238092 - usb-storage not automatically loaded
usb-storage not automatically loaded
Status: CLOSED DUPLICATE of bug 204396
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
Reported: 2007-04-26 22:54 EDT by David Zeuthen
Modified: 2013-03-05 22:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-02 11:55:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lshal (148.05 KB, text/plain)
2007-04-26 22:55 EDT, David Zeuthen
no flags Details
lspci (11.98 KB, text/plain)
2007-04-26 22:56 EDT, David Zeuthen
no flags Details
lsusb (30.24 KB, text/plain)
2007-04-26 22:56 EDT, David Zeuthen
no flags Details
modprobe.conf (227 bytes, text/plain)
2007-04-26 22:59 EDT, David Zeuthen
no flags Details

  None (edit)
Description David Zeuthen 2007-04-26 22:54:23 EDT
Description of problem:

On my x86_64 desktop box with a built-in USB1.1 4in1 card reader, usb_storage
isn't automatically loaded on bootup. Only by manually doing 'modprobe
usb_storage' or attaching a USB harddisk it shows up. 

I believe, but I may be wrong, this is due to libusual (which is one attempt at
doing user-configurable driver binding). 

Anyway, I think this is unacceptable from an end-user point of view so I'm
marking this as a Fedora 7 blocker. Thanks.

Will attach output of lspci, lsusb and lshal.

Version-Release number of selected component (if applicable):

# rpm -q module-init-tools udev kernel
Comment 1 David Zeuthen 2007-04-26 22:55:42 EDT
Created attachment 153568 [details]
Comment 2 David Zeuthen 2007-04-26 22:56:21 EDT
Created attachment 153569 [details]
Comment 3 David Zeuthen 2007-04-26 22:56:52 EDT
Created attachment 153570 [details]
Comment 4 David Zeuthen 2007-04-26 22:59:35 EDT
Created attachment 153571 [details]

Pretty standard modprobe.conf - nothing special in /etc/modprobe.d either

# ls -l /etc/modprobe.d/
total 28
-rw-r--r-- 1 root root	809 2007-04-10 07:32 blacklist
-rw-r--r-- 1 root root	833 2007-03-22 15:13 blacklist-compat
-rw-r--r-- 1 root root 5717 2007-03-22 15:13 modprobe.conf.dist
Comment 5 David Zeuthen 2007-05-02 11:55:18 EDT

*** This bug has been marked as a duplicate of 204396 ***

Note You need to log in before you can comment on or make changes to this bug.