Bug 238112 - libstdc++.a symbolic link to non existing file
libstdc++.a symbolic link to non existing file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 04:50 EDT by Feike Boomstra
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 05:03:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Feike Boomstra 2007-04-27 04:50:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10

Description of problem:
I have installed intel's icpc compiler in FC6.
When I try to compile a simple program I get the following output:

[feike@feike ~]$ icpc -fast HelloWorld.c++
IPO: performing single-file optimizations
IPO: generating object file /tmp/ipo_icpcLfw3xp.o
ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.1.1/32/../libstdc++.a when searching for -lstdc++
ld: cannot find -lstdc++
[feike@feike ~]$ 

I did some more investigations:
/usr/lib/gcc/x86_64-redhat-linux/4.1.1/32/libstdc++.a

is a symbolic link to:
 -> ../../../i386-redhat-linux/4.1.1/libstdc++.a

but this file does not exist. Even the directory doesn't exist.

I have installed:

compat-libstdc++-33-3.2.3-61
but that doesn't help.






Version-Release number of selected component (if applicable):
gcc-4.1.1-51.fc6

How reproducible:
Always


Steps to Reproduce:
1.icpc -fast HelloWorld.c++
2.
3.

Actual Results:
Doesn't compile.
ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.1.1/32/../libstdc++.a when searching for -lstdc++
ld: cannot find -lstdc++

Expected Results:
correct compilation and linking.

Additional info:
Comment 1 Jakub Jelinek 2007-04-27 05:03:37 EDT
If you want to link 32-bit C++ programs on x86_64, you need to make sure
libstdc++-4.1.*.i386.rpm is installed.
Comment 2 Feike Boomstra 2007-04-27 07:08:47 EDT
The i386 as well as the x86_64 is installed, but it doesn't provide the file
/usr/lib/gcc/i386-redhat-linux/4.1.1/libstdc++.a


[feike@feike ~]$ rpm -q libstdc++
libstdc++-4.1.1-51.fc6
libstdc++-4.1.1-51.fc6
[feike@feike ~]$ rpm -ql libstdc++
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.8
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.8
Comment 3 Jakub Jelinek 2007-04-27 07:15:02 EDT
Yeah, but you certainly don't have libstdc++-devel-4.1.1-51.fc6.i386.rpm
installed.  libstdc++ is the runtime library only package, libstdc++-devel
is for compilation/linking against that.
Comment 4 Feike Boomstra 2007-04-27 08:39:45 EDT
You are right, but I have the libstdc++-devel-4.1.1-51.fc6.x86_64.rpm installed, 
[feike@feike ~]$ rpm -qi libstdc++-devel
Name        : libstdc++-devel              Relocations: (not relocatable)
Version     : 4.1.1                             Vendor: Red Hat, Inc.
Release     : 51.fc6                        Build Date: Sat 06 Jan 2007 08:26:12
PM CET
Install Date: Sun 22 Apr 2007 10:33:20 AM CEST      Build Host:
ls20-bc1-14.build.redhat.com
Group       : Development/Libraries         Source RPM: gcc-4.1.1-51.fc6.src.rpm
Size        : 75468132                         License: GPL
Signature   : DSA/SHA1, Wed 10 Jan 2007 04:22:34 PM CET, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://gcc.gnu.org
Summary     : Header files and libraries for C++ development
Description :
This is the GNU implementation of the standard C++ libraries.  This
package includes the header files and libraries needed for C++
development. This includes rewritten implementation of STL.



and rpm refuse to install the i386 package:

package allready installed.
Comment 5 Jakub Jelinek 2007-04-27 08:53:12 EDT
Not sure how you tried to install it, it certainly works for me.
E.g.
yum install libstdc++-devel.i386
works just fine.
Comment 6 Feike Boomstra 2007-04-27 09:35:54 EDT
You are right, yum works fine. I've got it working.

(Nb. What I tried: I downloaded the rpm file and in the download window there is
an option open. With that installer I was not able to install the package.)

Appearantly it was not a bug, so you are welcome to close it right away, but can
you tell me where I can find the info how to solve such an issue myself?

Anyway, thanks a lot,
kind regards,
Feike Boomstra
Comment 7 Feike Boomstra 2007-04-28 04:49:45 EDT
With all things running, I finally was able to find out how things went. In one
way or another I had installed the i386 version of the compiler. Appearantly
there is a dependency missing to the devel library.

Note You need to log in before you can comment on or make changes to this bug.