Bug 238113 - Wrong init script
Summary: Wrong init script
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 237789 238114 238115
TreeView+ depends on / blocked
 
Reported: 2007-04-27 08:50 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 08:32:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0256 normal SHIPPED_LIVE hal bug fix update 2010-03-29 12:47:57 UTC

Comment 2 Richard Hughes 2009-01-20 11:07:54 UTC
Michal, does the init file look okay upstream? http://cgit.freedesktop.org/hal/tree/hald/haldaemon.in

Comment 3 Zack Cerza 2009-03-24 17:11:09 UTC
Whoa. Making comment #0 private because of links to intranet.corp.

Also, ack.

Comment 4 Zack Cerza 2009-05-04 19:02:09 UTC
(In reply to comment #2)
> Michal, does the init file look okay upstream?
> http://cgit.freedesktop.org/hal/tree/hald/haldaemon.in  

No. From the upstream script:

# Sanity checks.
[ -x @sbindir@/hald ] || exit 0

is the problem.

Comment 5 Richard Hughes 2009-05-12 11:54:19 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > Michal, does the init file look okay upstream?
> > http://cgit.freedesktop.org/hal/tree/hald/haldaemon.in  
> 
> No. From the upstream script:
> 
> # Sanity checks.
> [ -x @sbindir@/hald ] || exit 0
> 
> is the problem.  

Can I just change this to || exit 1, or should the line be removed altogether? I don't see how the init.d script could be installed, but not /usr/sbin/hald, as they are in the same package. It seems an odd check.

I can keep this for 5.4, or punt it to 5.5 as it's not ever triggered unless you've got a very broken system.

Comment 6 Richard Hughes 2009-05-12 15:18:27 UTC
Quite a few of the other init scripts have the same sanity check as hal, exiting with status zero.

Comment 7 Zack Cerza 2009-05-12 17:29:09 UTC
Changing it to exit 1 would be fine. I agree, this is a pedantic bug report. It'd be a good idea to fix the rest of the init scripts, as exiting 0 is the wrong thing to do, but... as you said, I'm not sure that if you managed to hit this bug, the exit code will be anywhere near the top of your list of things to care about.

Comment 14 errata-xmlrpc 2010-03-30 08:32:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0256.html


Note You need to log in before you can comment on or make changes to this bug.