Bug 238120 - httpd update creates unwanted /etc/httpd/conf.d/*.conf files
httpd update creates unwanted /etc/httpd/conf.d/*.conf files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 06:03 EDT by Vlado Potisk
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 05:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2007-04-27 06:03:59 EDT
Description of problem:
The httpd program reads all /etc/httpd/conf.d/*.conf files when starting
(according to the README there). That's why I assume that the normal way to
disable any of these files is to remove or rename them. However update creates
them again and thus alters the configuration in an unexpected way.

Version-Release number of selected component (if applicable):
httpd-2.2.4-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. install httpd, but not the latest version
2. delete e.g. /etc/httpd/conf.d/proxy_ajp.conf
3. yum update
4. restart httpd
  
Actual results:
The unwanted /etc/httpd/conf.d/proxy_ajp.conf re-appears. On my server the httpd
failed to start due to missing modules that I commented out in the config file
but which are required by proxy_ajp.

Expected results:
/etc/httpd/conf.d/*.conf files should be created as .rpmnew files if the
original file does not exist.
Comment 1 Joe Orton 2007-04-30 05:12:39 EDT
Sorry about that, but this is expected behaviour with RPM (perhaps unfortunate
in this case).   The way to reliably prevent the ajp module loading would be to
do something like:

  # echo > /etc/httpd/conf.d/proxy_ajp.conf
Comment 2 Vlado Potisk 2007-04-30 05:44:38 EDT
Thank you for quick response. Even if it is not a bug, I would suggest to append
a note about this to /etc/httpd/conf.d/README.

Note You need to log in before you can comment on or make changes to this bug.