Bug 238133 - Wrong init script
Wrong init script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: inn (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
: Reopened
Depends On:
Blocks: 237789 238134
  Show dependency treegraph
 
Reported: 2007-04-27 08:56 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 11:00:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.09 KB, patch)
2007-05-22 08:12 EDT, Ondrej Dvoracek
no flags Details | Diff

  None (edit)
Description Michal Marciniszyn 2007-04-27 08:56:37 EDT
Description of problem:
In the innd script, there are several constructions that make it possible to end
script with error code 0 while the service is not running. For example:
[ "${NETWORKING}" = "no" ] && exit 0
[ -d /etc/news ] || exit 0
[ -f /etc/news/inn.conf ] || exit 0
. /usr/lib/news/lib/innshellvars || exit 0
[ -d "$SPOOLBASE" ] || exit 0
There is also minor error with incorrect error code of unimplemented script feature.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service innd start/status
3. echo $?
  
Actual results:
0

Expected results:
correct error code/status code of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Ondrej Dvoracek 2007-05-22 08:12:59 EDT
Created attachment 155158 [details]
Proposed patch

Please, try this patch and let me know.
Comment 2 RHEL Product and Program Management 2007-06-05 16:28:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 10 errata-xmlrpc 2008-10-15 11:00:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0917.html

Note You need to log in before you can comment on or make changes to this bug.