Bug 23814 - GUI fallback to text produces black band across middle of screen
GUI fallback to text produces black band across middle of screen
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-11 15:28 EST by Brent Nordquist
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 19:00:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Nordquist 2001-01-11 15:28:13 EST
[Installing Florence beta-2 from Local CD-ROM on some older 486 hardware,
using "linux dd" at the LILO: prompt.  It attempted to start X as follows:]

Using X server /usr/X11R6/bin/XF86_FBDev
Can't open /dev/fb0
going to test the x server
tested the x server
Waiting for X server to start .......... X server started successfully.

[Now at this point the screen streched a little taller so that the lowest
line was only half-visible; I believe it was something like:]

GUI installer startup failed - falling back to text mode

[Then a horizontal black band appeared in the upper-middle of the screen.
The familiar blue background of the TUI installer appeared, but the black
band was obscuring it, even when the menus began to appear, etc.
Installing became impossible because you can't read what's under the black
band.  Hardware:  486DX-100 with 48MB RAM, Weitek P9000 video, NANAO
FLEXSCAN F550i monitor.]
Comment 1 Michael Fulbright 2001-01-12 10:24:25 EST
Try booting with 'lowres' on the boot command line with any other parameters you
require.
Comment 2 Brent Nordquist 2001-01-12 10:39:05 EST
Same result after adding the "lowres" option (I used "linux dd lowres").  (And
how would a user know to do this?)

I noticed this time that just before "GUI installer startup failed" the screen
fills momentarily with random text-mode characters in lots of different
fore/background colors.  It looks (to my uneducated eye) like it's writing
something to the video memory that messes up text mode after that?
Comment 3 Glen Foster 2001-01-15 16:50:57 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Brent Nordquist 2001-02-01 14:12:35 EST
Fisher 7.090 appears to have taken care of this; pressing Enter at LILO: now
goes right into text mode without trying graphical; an explicit "text" is no
longer required.

Note You need to log in before you can comment on or make changes to this bug.