Bug 238144 - rhn-httpd generated mixed format logs
rhn-httpd generated mixed format logs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: 271101 454471
  Show dependency treegraph
 
Reported: 2007-04-27 09:59 EDT by Martin Poole
Modified: 2010-10-22 10:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-17 10:52:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2007-04-27 09:59:49 EDT
Description of problem:

the apache configuration shipped with satellite produces logs in both common and
combined formats which makes analysis difficult.


Version-Release number of selected component (if applicable):

rhn-apache-1.3.27-24.rhn.rhel4
/etc/httpd/conf/httpd.conf

How reproducible:

Always

Steps to Reproduce:
1. Access a satellite with a secure, and insecure URL.
2.
3.
  
Actual results:

192.168.106.125 - - [16/Apr/2007:09:59:34 +0200] "GET
/download/1176753377/37c4a965c119cf687c0ef6bee0c66a726e1dbc53/0/0/redhat/NULL/up2date/4.4.69-25/x86_64/up2date-4.4.69-25.x86_64.rpm
HTTP/1.0" 200 18
79387 "-" "Wget/1.10.2 (Red Hat modified)"
192.168.106.125 - - [16/Apr/2007:09:59:35 +0200] "GET
/download/1176753377/6b322f756f4d5cec84394e81e337cfc87791ae4f/0/0/redhat/NULL/up2date-gnome/4.4.69-25/x86_64/up2date-gnome-4.4.69-25.x86_64.rpm
HTTP
/1.0" 200 107552 "-" "Wget/1.10.2 (Red Hat modified)"
192.168.106.125 - - [16/Apr/2007:09:59:35 +0200] "POST /XMLRPC HTTP/1.1" 200 770
192.168.106.125 - - [16/Apr/2007:09:59:36 +0200] "POST /XMLRPC HTTP/1.1" 200 2136
192.168.106.125 - - [16/Apr/2007:09:59:36 +0200] "POST /XMLRPC HTTP/1.1" 200 121
192.168.106.125 - - [16/Apr/2007:09:59:36 +0200] "POST /XMLRPC HTTP/1.1" 200 121
192.168.106.125 - - [16/Apr/2007:09:59:37 +0200] "POST /XMLRPC HTTP/1.1" 200 121
192.168.106.125 - - [16/Apr/2007:09:59:37 +0200] "POST /XMLRPC HTTP/1.1" 200 3134
192.168.106.125 - - [16/Apr/2007:09:59:37 +0200] "POST /XMLRPC HTTP/1.1" 200 1552
192.168.106.125 - - [16/Apr/2007:09:59:39 +0200] "GET
/XMLRPC/$RHN/rhel-x86_64-es-4/listPackages/20070416080042 HTTP/1.1" 200 39177
192.168.106.125 - - [16/Apr/2007:09:59:40 +0200] "GET
/XMLRPC/$RHN/rhel-x86_64-es-4-extras/listPackages/20070416080042 HTTP/1.1" 200 949


Expected results:

Consistent format (always combined)

Additional info:

The problem is caused by the inclusion of a TransferLog clause in the secure
host block

  <VirtualHost _default_:443>

  #  General setup for the virtual host
  #DocumentRoot "/etc/httpd/htdocs"
  #ServerName new.host.name
  #ServerAdmin you@your.address
  ErrorLog logs/error_log
  TransferLog logs/access_log

This overrides the definition earlier in the file

  CustomLog logs/access_log combined

but only applies to secured access. This results in mixed formats in a single
log file.

It should be sufficient to remove the clause in the secure block.
Comment 1 Mike McCune 2007-05-02 15:45:01 EDT
no time to fix this in 500
Comment 3 Milan Zazrivec 2008-07-17 10:43:26 EDT
The httpd setup on Satellite 5.1.0 and newer uses combined format for
access_log (log for insecure acccess) and common format for ssl_access_log
(log for secure access).

The httpd setup on Satellite 5.1.0 also no longer mixes two different
log formats in a single log file.

Note You need to log in before you can comment on or make changes to this bug.