Bug 238171 - Can't save config for dual head with I910 integrated video card
Can't save config for dual head with I910 integrated video card
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 13:15 EDT by Joseph Harnish
Modified: 2009-07-14 12:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 511953 (view as bug list)
Environment:
Last Closed: 2009-07-14 12:48:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -v on a Dell Latitude X1 using the Fedora 7 Test 4 KDE Live CD (6.43 KB, text/plain)
2007-05-10 16:09 EDT, MartinG
no flags Details
dmesg on a Dell Latitude X1 (26.34 KB, text/plain)
2007-05-10 16:10 EDT, MartinG
no flags Details
Xorg.0.log "Fatal server error: Caught signal 11. Server aborting" (44.90 KB, text/plain)
2007-05-10 16:12 EDT, MartinG
no flags Details
Xorg.0.log (not crashing) (42.66 KB, text/plain)
2007-05-10 16:14 EDT, MartinG
no flags Details

  None (edit)
Description Joseph Harnish 2007-04-27 13:15:44 EDT
Description of problem:
I am trying to configure dual monitor via system-config-display on a form factor
Dell computer.  It is an Intel i910 with a cable that has a DVI output and a vga
output.  When I try and configure dual head using system-config-display it
doesn't allow me to save my configuration.  Even if I boot up with a bad config
and go into the configuration mode and kick of the gui config tool it comes up
with the config that I want to use but even in that tool it won't save the
configuration when I set it up that way.  I know it is hard to explain so I am
available to provide other information that you need.

Version-Release number of selected component (if applicable):
system-config-display-1.0.48-1.fc7

How reproducible:


Steps to Reproduce:
1.  run system-config-display
2.  check use dual head
3.  can't save.
  
Actual results:


Expected results:


Additional info:
Comment 1 MartinG 2007-05-10 16:06:18 EDT
I have a similar problem:
I booted the Fedora 7 KDE Live CD test4 (loaded in ram as I've got 1.2GB) on my 
Dell Latitude X1 (Intel Corporation Mobile 915GM/GMS/910GML Express Graphics 
Controller (rev 03))

The livecd correctly chose the 'intel' driver (not the i810 driver) in my 
xorg.conf, and for the first time Fedora worked with the correct widescreen 
resolution of 1280x768 out of the box - nice :) (since Fedora Core 4 I have 
used the 915resolution hack)

So, I hooked up an external flatscreen monitor (not using DVI plug, but the old 
one) and wanted to run dual head, thus started system-config-display from a 
'konsole'.

Click "Dual head" tab, click "Use dual head", click "OK".

Nothing happens, but I get this traceback:

[fedora@localhost ~]$ system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 152, in ok
    second_monitor = self.xconfig.monitor[1]
IndexError: index out-of-bounds

So, I select "Second Monitor Type" (was: No monitor selected), choose "LCD 
Panel 1280x1024"
Resolution: Not possible to choose 1280x1024, max is the same as the
internal format of the laptop monitor, namely widescreen 1280x768.
I can choose 1024x768, and do that.
I set "Desktop layout": "Individual Desktops".
Press OK -> get a message that I have to restart the X server, OK, do that: 
End current session.
Login again.

Now I get 1280x1024 resolution _on both screens_. So I cannot see the KDE menu 
(that is on the bottom of the screen) on the widescreen display of my laptop.
To clarify: on the external LCD screen I get 1280x1024, but on the internal 
laptop screen I get 1280x768 resolution but a 1280x1024 desktop area (not 
moving with the mouse)

I now open 'system-config-display' click the dual head tab and see
Second Monitor Type: None (ie. it was not saved)
Resolution: 1280x1024. (ie. not the one i chose, but in fact the one I 
wanted...)

Okey...
Now I choose "Desktop layout": "Spanning desktops"
and click OK (without setting any monitor type)
I then get promptet for the monitor type. (which I didn't the first time)
I choose 'Generic LCD Panel 1280x1024' and click OK, OK. Then end current 
session and relogin.

That doesn't work: Both screens switch from black to white about four or five 
times, and the keyboard seems to have stopped working (no response on caps look 
for instance). I end up with pressing ctrl-alt-backspace to kill the X server, 
still have a black screen, no consoles working (ctlr-alt-f1), no effect on 
monitor switch (Fn-F8 on my laptop), but ctrl-alt-del brings down the system 
safely.

Thanks for any help on this, I'll try to provide some more logs etc if you give 
me the directions (the live cd is a bit unusable in the test4 stage as 
'prelink' and 'makewhatis' eats the cpu and make 'loop121' loockup or 
something...)

-MartinG
Comment 2 MartinG 2007-05-10 16:09:42 EDT
Created attachment 154494 [details]
lspci -v on a Dell Latitude X1 using the Fedora 7 Test 4 KDE Live CD

lspci -v on Dell X1
Comment 3 MartinG 2007-05-10 16:10:49 EDT
Created attachment 154495 [details]
dmesg on a Dell Latitude X1
Comment 4 MartinG 2007-05-10 16:12:23 EDT
Created attachment 154496 [details]
Xorg.0.log "Fatal server error: Caught signal 11. Server aborting"
Comment 5 MartinG 2007-05-10 16:14:22 EDT
Created attachment 154497 [details]
Xorg.0.log (not crashing)
Comment 6 Matěj Cepl 2007-11-14 10:47:51 EST
Could you try Fedora 8 Live CD?
Comment 7 Matěj Cepl 2008-01-17 10:46:09 EST
... that or the current Rawhide. If you won't reply in one month, I will have to
close this bug as INSUFFICIENT_DATA. Thank you.
Comment 8 Joseph Harnish 2008-01-17 11:04:45 EST
Saving now works with Fedora 8.  Although the generated config does not actually
work but that is a different ticket.  On the mailing list a discussion on the
way these intel cards work seems to shed some light how to get the multihead to
work:
https://www.redhat.com/archives/fedora-devel-list/2008-January/msg01525.html

Not sure if you want to keep this open because some of the replies seem to be
the intel dual head issue.
Comment 9 MartinG 2008-01-17 11:52:18 EST
Using Fedora 8 (stable), fully updated (yum).
kernel 2.6.23.9-85.fc8
xorg-x11-drv-i810-2.1.1-7.fc8

Disabled compiz-fusion.

$ system-config-display
/usr/share/system-config-display/xConfigDialog.py:496: GtkWarning:
Failed to set text from markup due to error parsing markup: Error on line 1 
char 94: Element 'markup' was closed, but the currently open
element is 'span'
  xml =  gtk.glade.XML("/usr/share/system-config-display/display.glade",  
domain="system-config-display")

Wrote my root password when prompted.
Internal resolution is 1280x768.

Wanted text in english (and not native Norwegian), and did instead:
$ LANG=C system-config-display
and did not get the warning listed above.

Went to "Dual head", checked "use dual head".
Second monitor: No monitor selected -> configure -> Generic LCD,
1600x1200 (known to work on my SyncMaster 204b).

Second video card:
Says "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
So I didn't change it, but it was listed twice.

Resolution: maximum was at 1280x768. I choose 1024x768, millions of
colors and Desktop layout: Individual desktops, pressed OK.

Got a message telling me that I need to log out and in again, and that
the config was saved as /etc/X11/xorg.conf and that a backup file was
created (/etc/X11/xorg.conf.backup). Checked the folder, and there
were in fact no backup file created (!).

Log out and in again:
The login screen showed up on both screens, at resolution 1600x1200
(not 1024x768 as I wanted). Therefore, I could not see the entire
desktop on the laptop. Otherwise the login worked fine.

So I tried again:
$ LANG=C system-config-display

Under "Settings", resolution said "1600x1200".
Under "Dual head", "use dual head" was selected, but "second monitor
type" now shows "No monitor selected".
Resolution shows "1600x1200", color: millions, and "Desktop layout" is
"individual desktops".

So I tried to reduce resolution to 1024x768. Hm, went back to settings
and checked - resolution there still says 1600x1200. Also changed that
to 1024x768. Pressed OK. Got a popup asking me to select the model of
my monitor - chose Generic LCD 1024x768. Checked both "Dual head" and
"Settings" and confirmed that resolution was unchanged. Pressed
OK. Got the message
"Display settings changed
You need to log out and restart the X server for the changes to take
effect.
Configuration was written to /etc/X11/xorg.conf, original
configuration saved as /etc/X11/xorg.conf.backup.
"
Again, no backup file was created.
Logged out and in again.

This worked - both screens are now at 1024x768, and shows exactly the
same.

Next, tried "spanning desktops". 

This did not seem to work - both screens still shows exactly the same,
ie. they are cloned. Funny thing though, the screens are still in
1024x768, but now system-config-display reports a resolution of
800x600 (both under "Settings" and "Dual head"). "Second monitor type"
is still at "LCD panel 1024x768", ie. the info is was not lost this
time.

Next, I tried to change back to only using my internal screen at 1280x768. That 
was not possible: After unchecking "use dual head", I was not able to choose 
2180x768 on the "Settings" tab.

Hope some of this might useful,
best regards,
-MartinG
Comment 10 Bug Zapper 2008-05-13 22:48:53 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Otto J. Makela 2008-09-11 10:50:40 EDT
Exactly the same problem on Fedora 9, system-config-display will not save settings when trying to switch to a dual head configuration. When starting from command line, the following error message is produced:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 201, in ok
    if card.getDescription() == self.secondVideocardOptionMenu.get_menu().get_active().get_data("NAME"):
AttributeError: 'NoneType' object has no attribute 'get_data'
Comment 12 Egon Kastelijn 2009-03-06 07:32:44 EST
Same problem here with an NVidia Geforce 9300M G on Fedora 10.
This problem seems to be the same as bug #443352.
Comment 13 Bug Zapper 2009-06-09 18:34:16 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Egon Kastelijn 2009-06-10 15:46:20 EDT
This problem still exists:
system-config-display-1.1.1-1.fc10.noarch
Comment 15 Bug Zapper 2009-07-14 12:48:34 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.