Bug 238188 - MySQL Administrator crashes on 'create schema' operation
MySQL Administrator crashes on 'create schema' operation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql-gui-tools (Show other bugs)
6
All Linux
high Severity urgent
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 15:45 EDT by Marcin Zajaczkowski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 5.0r12-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 19:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Zajaczkowski 2007-04-27 15:45:30 EDT
Description of problem:
MySQL Administrator crashes on 'create schema' operation. Error message in a
console:
./mysql-adinistrator: line 103: 9637 Segmentation fault      $PRG-bin $args

It's impossible to create schema (table) using that tool.


Version-Release number of selected component (if applicable):
mysql-administrator-5.0r11-3.fc6

How reproducible:
Always

Steps to Reproduce:
1. Connect to some database
2. Try to call 'create schema'

Actual results:
Segmentation fault with message given above

Expected results:
Schema (table) should be created

Additional info:
Described problem is caused by a bug http://bugs.mysql.com/bug.php?id=27685
which was just fixed. It can take some time to a release of the next version of
mysql-administrator and problem is serious (create table is very common
operation), so proper patch (available in the MySQL source repository) could be
 used against 5.0r11-3 available in FE to provide quick fix.
Comment 1 Dennis Gilmore 2007-06-17 16:18:50 EDT
updated build going into updates-testing  please test and report back.

moving to correct component mysql-administrator is no longer standalone.
Comment 4 Marcin Zajaczkowski 2007-06-18 04:31:06 EDT
Unfortunately I can't test it. Those packages are for F7, while I have FC6. I
tried to rebuild it manually, but mysql-query-browser requires libgtkhtml-3.14
(in FC6 is 3.12). *Note* that Lack of that version was detected by configure
script, not by RPM dependencies (you could add required version in SPEC file).

I tried to update libgtkhtml, but libgtkhtml-3.8.so.15 (from 3.12) is required
also by evolution which a lot of packages depends on, so I can't uninstall it.

Do you plan to move 5.0r12 to the FC6 branch? If yes, an actualization of other
packages might be required. If no, maybe you could only backport specified patch?
Comment 5 Dennis Gilmore 2007-06-18 08:00:55 EDT
the version for FC-6 will go out with the next push  It was built at the same 
time. It should hit mirrors today or toomoorow
Comment 6 Marcin Zajaczkowski 2007-06-18 08:18:53 EDT
Hmm, so why I had compilation error on FC6?

checking for GLIB... yes
checking for GNOME... configure: error: Package requirements (libglade-2.0
                        gthread-2.0
                        libxml-2.0 >= 2.6.2
                        libgtkhtml-3.14
                        gtkmm-2.4) were not met:

No package 'libgtkhtml-3.14' found

[marcinz@bolger mysql]$ rpm -qa | grep gtkhtml
gtkhtml2-2.11.0-3
gtkhtml3-3.12.3-1.fc6
gtkhtml3-devel-3.12.3-1.fc6

Did you also update gtkhtml3 package in the FC6 repository?
Comment 7 Dennis Gilmore 2007-06-18 08:33:34 EDT
you could try with rpmbuild --rebuild --define="fedora 6" --define="dist .fc6" 
<src.rpm>

there is some release specific portions in the spec file that deal with the 
different versions.
Comment 8 Marcin Zajaczkowski 2007-06-18 08:46:59 EDT
Ok, I didn't know about those switches. I will try to get version built by you
from a repository.
Comment 9 Fedora Update System 2007-06-18 12:37:07 EDT
mysql-gui-tools-5.0r12-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Marcin Zajaczkowski 2007-06-20 05:27:12 EDT
'Create schema' works just fine with updated version on FC6.
Closing bug.
Comment 11 Fedora Update System 2007-06-25 19:23:23 EDT
mysql-gui-tools-5.0r12-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.