Bug 238231 - IMSmap screensaver freezes system for several minutes
IMSmap screensaver freezes system for several minutes
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 23:03 EDT by Tom Horsley
Modified: 2008-05-06 21:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 21:35:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My current xorg.conf file (1.66 KB, text/plain)
2007-05-21 18:47 EDT, Tom Horsley
no flags Details
My original xorg.conf file (818 bytes, text/plain)
2007-05-21 18:49 EDT, Tom Horsley
no flags Details
My current Xorg.0.log file (goes with current xorg.conf file). (60.76 KB, text/plain)
2007-05-21 18:53 EDT, Tom Horsley
no flags Details
X log while running with no xorg.conf file (53.31 KB, text/plain)
2007-05-21 19:04 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2007-04-27 23:03:19 EDT
Description of problem:

I installed all the packages from extras with screensaver in the name because
they usually exercise the video drivers pretty well, and I wanted to see how
the latest xorg radeon driver worked. As I was going through the previews
(using the screensaver preference app, not the full screen preview), I got
to IMSmap, and the preview drew some funny looking cloudy thing, then the
system was completely froze up. The mouse moved, but clicking on things
did nothing, and Ctrl-Alt-F1 didn't switch to a console. I spent a few minutes
poking around, and was about to press the reset button, when the system finally
unlocked and the Ctrl-Alt-F1 happened. I took advantage of it being responsive
again to reboot back into FC6.

Version-Release number of selected component (if applicable):

I'm back in FC6 now, so I can't say which version, but it is whatever I got
from the FC7t4 DVD install plus any recent updates that might have
changed things.

How reproducible:

Not really anxious to try it again and find out :-).

Steps to Reproduce:
1. see description.

Additional info:

AMD Athlon 64 X2 4400+ dual core cpu,
2 gig of memory,
Sapphire Radeon X700 Pro PCIe video adaptor ,
BIOSTAR TForce4U socket 939 motherboard (nforce4 chipset I believe)

I report this against the ATI drivers merely because they seem to be the
most likely cause of the problem, not because I'm sure that's the right
component to use.
Comment 1 Tom Horsley 2007-04-28 18:14:37 EDT
I just tried this again running as a normal user rather than as root, and I see
the same freeze, so it seems more likely than ever to be a driver issue and
not something it did like raise its priority since I was running as root.

I've also noticed other screensaver related weirdness, but I don't know if
if is related to the driver, or the screensaver software. For instance, the
"Lattice" screensaver won't preview in fullscreen, but if I set it as the
screensaver and just wait for it to come on, it seems to work fine.
Comment 2 Matěj Cepl 2007-05-21 11:55:57 EDT
There are two things:

a) Xorg is really not good in working as a root user,

b) Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below. Could you please also
try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your
display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt
as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Tom Horsley 2007-05-21 18:47:31 EDT
Created attachment 155136 [details]
My current xorg.conf file

This xorg.conf file is kinda hairy and complicated because I found that
I still need my mode line fix for xorg bug 8790 at
https://bugs.freedesktop.org/show_bug.cgi?id=8790

This xorg.conf is basically a copy of the one I built for FC6 to work
around the same bug.
Comment 4 Tom Horsley 2007-05-21 18:49:35 EDT
Created attachment 155137 [details]
My original xorg.conf file

This is the original anaconda-generated (or whoever generated it) xorg.conf
file I had right after installing. I first encountered the bug when using
this file.
Comment 5 Tom Horsley 2007-05-21 18:53:02 EDT
Created attachment 155138 [details]
My current Xorg.0.log file (goes with current xorg.conf file).

Here is the current log file that was generated when starting X with
the 1st xorg.conf file I attached.
Comment 6 Tom Horsley 2007-05-21 19:04:06 EDT
Created attachment 155139 [details]
X log while running with no xorg.conf file

Here's the X log when there is no xorg.conf file (it doesn't seem to have
generated one either, it is just running without one).

I have also (while running in this mode) just tried to preview the screensaver
again, and it still seems to freeze up the system, though perhaps not as long
as it did originally (either just random variation, or the fact that I have
applied several updates since the original report changed something).
Comment 7 Tom Horsley 2007-05-21 19:05:43 EDT
By the way, I was running as a plain Joe User, not as root when doing this
last test.
Comment 8 Bug Zapper 2008-04-03 20:20:13 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 9 Bug Zapper 2008-05-06 21:35:35 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.