Bug 238240 - Network Manager incorrectly detect Intel PRO/wireless 3945ABG on Thinkpad T60
Network Manager incorrectly detect Intel PRO/wireless 3945ABG on Thinkpad T60
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 00:59 EDT by Edmond Hui
Modified: 2013-03-05 22:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 11:21:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edmond Hui 2007-04-28 00:59:37 EDT
Description of problem:

Network Manager detects Intel PRO/Wireless 3945ABG wireless on Thinkpad T60
(2623P2U) as a ethernet device. Therefore, unable to setup the wireless device.

How reproducible:

Steps to Reproduce:
1. install FC7t4
2. after install and first-boot, open networkmanager
  
Actual results:

"wmaster0" device is setup, but as a ethernet device. So, user is unable to set
SSID, key and such.

Expected results:
The device should be detects as a wireless device, so user can set SSID and key,
and such

Addition info:
Try delete the device and redetect, same result.

see smolt record
http://smolt.fedoraproject.org/show?UUID=c10676cb-7d0a-4d31-9a6b-26d632cd050c
Comment 1 Christopher Aillon 2007-04-28 11:00:30 EDT
NetworkManager does no detection, it only goes based on what hal and the kernel
return.  Trying hal.
Comment 2 Edmond Hui 2007-05-14 10:42:07 EDT
Any new on this? F7 is coming and this one seem untouch? I tried the latest
rawhide Live and the problem is still there.....

Rgds,
Comment 3 Edmond Hui 2007-06-06 21:53:29 EDT
Try this again on F7 release actual. It's working now

Note You need to log in before you can comment on or make changes to this bug.