Bug 238243 - anaconda overestimates/greedy disk space requirements for upgrade
anaconda overestimates/greedy disk space requirements for upgrade
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 03:51 EDT by David Timms
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 15:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dh -h on the machine before the required reboot. (538 bytes, text/plain)
2007-04-28 03:51 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2007-04-28 03:51:04 EDT
Description of problem:
Attempting an pxeboot/ftp upgrade of an fc6 {up2 2007-04-20}, anaconda decides
there is not enough disk space, yet there appears to be plenty. 

Additionally, the only option at this stage is to reboot, where a skilled nixer
might be able to move files to make more space available. An option to request
recheck of disk space could allow the upgrade to succeed.

Version-Release number of selected component (if applicable):
F-6.93-i386-DVD.iso

How reproducible:
requires limited disk space on /

Steps to Reproduce:
0. install fc6 default packages and update to 2007-04-20
1. disk has 1.1GB { 1,122,628 } free on /
2. pxeboot + ftp
3. upgrade
4. ... creating upgrade transaction ...

Actual results:
~warning saying please make 284M of space available on the / partition.
Only a Reboot option is available.

Expected results:
Install runs and completes.

Additional info:
With enough space for two CD's most people would expect the upgrade to succeed.

If nothing changes to improve the efficiency of the installer, then the Release
Notes need to state the expected disk requirements during the upgrade process.
I'm about to do a bit of testing to find a range.
Comment 1 David Timms 2007-04-28 03:51:04 EDT
Created attachment 153689 [details]
dh -h on the machine before the required reboot.
Comment 2 David Timms 2007-04-28 04:26:16 EDT
I thought there is something weird with the result of df before the install. It
actually mentions the 1008M /dev  {or /mnt/sysimage/dev} line 3 times. I
wondered whether this is an on / partition swap file - perhaps consuming the space.
===
Increased the space available to 1,304,000 KB, this allowed the install to
complete. The following amount of space was begin used during the install:
/ free    no/700  package name
1,304,176 before package analysis.
1,113,444 after analyis suceeds and some way into the install
1,087,248    290  cypteset..
  958,960    426  metacity..
  826,852    528  esc..
  783,408    546  gstreamer..
  579,480    548  openoffice.org-core..
  540,560    565  control-center..
  517,692    -    gnome-bluet..
  433,040    582  fast-user..
  378,576    597  sound-jui..
So it looks like anaconda really does need the space.

It appears the upgrade is performed similarly to a yum update {group of files},
in that all the new versions get installed to disk first. Then when that is
complete, old packages are removed from disk {=~cleanup}. Some heavy consumers
of space during the upgrade include openoffice {in two differing folders},
firefox, evolution.

Once the 700/700 packages are complete, for the next 12 minutes, the cleanup
must be happening because the available space climbs to
600,800,1137,1173,1229,1420 MB.

Is it possible to do cleanups during the install, and hence not require so much
free space during the upgrade ?
Secondly, isn't it likely to worsen file fragmentation on the disk if you:
- have something present
- add a second updated thing
- remove the original something ?
Comment 3 David Timms 2007-04-28 05:25:34 EDT
I should have mentioned that displaying a decent message to the user is far
better than the disk space exception problems of older bugs 152137 and 186451.
Comment 4 Jeremy Katz 2007-04-30 15:05:38 EDT
Changing the ordering needs to be done at the rpm level (and thus filter up to
everything including yum and anaconda) rather than hacks in anaconda.  There's
already something filed to that effect against rpm so closing this one WONTFIX

Note You need to log in before you can comment on or make changes to this bug.