Bug 238246 - Hal mounts new volumes (removable media) as root
Hal mounts new volumes (removable media) as root
Status: CLOSED DUPLICATE of bug 234716
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 04:44 EDT by Oded Arbel
Modified: 2013-03-05 22:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-28 14:30:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2007-04-28 04:44:41 EDT
Description of problem:
When a normal user is logged in, and the user plugs in a USB storage device, HAL
automatically mounts the new device under the /media directory. 
In Fedora Core 6 the new volume had the ownership of the logged in user, which
allowed the user to modify the contents of the device.
Starting with Fedora Core 7 (not sure which test - I've seen it in test 2 and
now in test3 and in rawhide of 1 week ago), HAL mounts the new media using
'root' ownership, which effectively makes the new device read-only.

Version-Release number of selected component (if applicable):
0.5.9-5.fc7

How reproducible:
Always

Steps to Reproduce:
1. Log in as a non-priviliged user
2. Plug in a USB mass storage device
3. Try to put some file into the device
  
Actual results:
Failed - no permissions

Expected results:
Success

Additional info:
Comment 1 David Zeuthen 2007-04-28 14:30:05 EDT

*** This bug has been marked as a duplicate of 234716 ***

Note You need to log in before you can comment on or make changes to this bug.