Bug 238266 - Anaconda needs > 370 MB RAM at Fedora 7 Test 4 (6.93) installation
Anaconda needs > 370 MB RAM at Fedora 7 Test 4 (6.93) installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-04-28 10:48 EDT by Robert Scheck
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 17:23:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (58.20 KB, text/plain)
2007-04-28 10:50 EDT, Robert Scheck
no flags Details
anacdump.txt (58.23 KB, text/plain)
2007-05-01 16:29 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2007-04-28 10:48:45 EDT
Description of problem:
A non-LVM installation of Fedora 7 Test 4 (6.93) crashes when trying to 
partition/format the disk. The file anacdump.txt is attached, the included 
function for remote copy the anaconda log seems to be broken, too.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.55-1

How reproducible:
Everytime when doing a non-LVM installation of Fedora 7 Test 4 (6.93).

Actual results:
Non-LVM installation of Fedora 7 Test 4 (6.93) crashes.

Expected results:
Work installation again ;-)
Comment 1 Robert Scheck 2007-04-28 10:50:31 EDT
Created attachment 153711 [details]
anacdump.txt
Comment 2 G.Wolfe Woodbury 2007-04-29 00:56:35 EDT
see also BZ 203044
Comment 3 G.Wolfe Woodbury 2007-04-29 01:06:32 EDT
Sorry that should be Bugzilla #232862 "Anaconda exception trying lvchange...."
Comment 4 Robert Scheck 2007-04-29 04:21:17 EDT
My bug report looks more or less like a duplicate, but these are on different 
archs, so I'll not mark mine as duplicate for now (maybe stuff has to be fixed 
somehow other on x86_64). Well, finally this bug report has to be fixed until 
F7, because otherwise I'm not able to have F7 on my laptop during LinuxTag ;-)
Comment 5 Robert Scheck 2007-05-01 06:44:49 EDT
Chris, please let me know when there's something to test, I'm willing to try.
Comment 6 Chris Lumens 2007-05-01 13:49:16 EDT
Did you have anything previously installed?  If possible, could you provide the
partition layout from before attempting installation and also the partition
layout you are attempting to set up in anaconda?  Thanks.
Comment 7 Robert Scheck 2007-05-01 14:29:59 EDT
I'm not changing the partition layout during the setup, I'm only selecting
that the already existing ext3 and swap partitions should be formatted using 
ext3 and swap. Partition size of / (hda3) is ~ 9 GB and size of the swap 
partition (hda2) is around 200 MB and the NTFS partition (hda1) is 70 GB. Oh 
and there's a working Windows XP system, yes. Do you need any special values 
from the partition setup or are these information enough?
Comment 8 Chris Lumens 2007-05-01 14:53:17 EDT
Well I am unable to reproduce this here.  It looks like we're not doing a very
good job of reporting the underlying error that's occurring.  Could you add the
parameter updates=http://people.redhat.com/clumens/238266.img to your command
line when you boot the install media and when it crashes again, attach the
exception dump to this bug report?  This just adds more useful logging so I can
see why lvm is failing.  Thanks.
Comment 9 Robert Scheck 2007-05-01 14:56:57 EDT
Why is LVM involved into this when I would like to do a non-LVM installation? 
Nevertheless, I'll re-start an F7t4 installation using the given parameter from 
above in the next time.
Comment 10 Chris Lumens 2007-05-01 15:00:29 EDT
At various times, we invoke the LVM commands to scan for any existing logical
volumes on the system.  We need this to do things like prompt you for which
system you want to upgrade, build the disk graph on the partitioning screen,
know what labels to avoid, etc.  In the case where there is no LVM on the
system, the commands should still just be returning nothing instead of causing
some crash, though.
Comment 11 Robert Scheck 2007-05-01 16:29:46 EDT
Created attachment 153889 [details]
anacdump.txt

Here is the file you're expecting. But when reading the log file myself, I'm
guessing that the problem is not enough memory to execute lvm successfully.
Unfortunately anaconda doesn't seem to use the new swap partition?!
Comment 12 Robert Scheck 2007-05-01 17:48:09 EDT
Okay, it's a memory problem, because the monster anaconda wastes about 373 MB 
of memory (my laptop has 512 MB RAM some of the RAM is shared with the graphics 
chip, so 373 MB are remaining) for the dependency resolving and partitioning/
formatting at the same time before freeing some of it.

Well, the textbased installation is not much better, it only abuses 369 MB of 
memory for dependency resolving and partitioning/formatting before freeing some 
of it. Next step is where yum (?) is downloading the packages ("Installation is 
starting, this can take some time") or so is displayed and the snake eats 
slowly my memory again and starts swapping of the newly created swap partition. 
So far so good. When having 50 MB swapped and aten another 372 MB of memory, my 
laptop simply rebooted - really nice feature, guys</irony>.
Comment 13 Robert Scheck 2007-05-01 17:54:21 EDT
Oh and if you're thinking, this isn't a bug nor a F7 blocker, please adapt the 
release notes at section "6.4.1. Hardware requirements for x86_64" to match at 
least a bit with the reality.
Comment 14 Chris Lumens 2007-05-02 10:55:10 EDT
Reassigning this back to anaconda-maint-list for wider consideration.  Do we
want to raise the memory threshold for enabling early swap, or is there
something else we can do before F7?  I've also seen this reported in the office
during vmware installs.
Comment 15 Roderick Johnstone 2007-05-02 10:59:59 EDT
I'm seeing this roo on a kickstart installation on x86_64 with 512MB.
Comment 16 Jeremy Katz 2007-05-02 17:29:39 EDT
(In reply to comment #14)
> Reassigning this back to anaconda-maint-list for wider consideration.  Do we
> want to raise the memory threshold for enabling early swap, or is there
> something else we can do before F7?  I've also seen this reported in the office
> during vmware installs.

I don't think we want to change the memory threshold I don't think...  need to
actually reproduce and then we can get a better idea of where things have gone.
Comment 17 Robert Scheck 2007-05-02 17:54:56 EDT
Chris, Jeremy and all the others, feel free to hit me, if you need some guy
for testing/reproducing or delivering information etc. Personally, this memory 
monster makes me worry when thinking about the install party at LinuxTag 2007. 

IMHO the main memory leak is the dependency resolving itself which eats the 
memory step by steap and frees nothing of it. Memory gets free'd after the lvm/
partitioning stuff was executed as it looks to me.
Comment 18 Robert Scheck 2007-05-06 17:28:54 EDT
Ping? IMHO time until F7 release is running away to fast and nothing happens?
Comment 19 Jeremy Katz 2007-05-07 17:23:13 EDT
Okay, did some investigating and reproduced with mem=384M.  We should probably
be a little bit more explicit about shared video memory really decreasing the
amount of memory that the system has and thus that exists as far as we're
concerned. 

But by bumping early swap up on 64bit platforms, we should at least avoid
problems and it's not too crazy since we do have higher requirements on those
platforms.

Note You need to log in before you can comment on or make changes to this bug.