Bug 238287 - Permission denied to write to the eggdrop's root dir
Permission denied to write to the eggdrop's root dir
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eggdrop (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 16:42 EDT by Andy Shevchenko
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-28 16:47:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Shevchenko 2007-04-28 16:42:30 EDT
Description of problem:
Eggdrop can't be started as root. It needs to start under ircd user (f.e.).
However ircd user can't write files to the eggdrop's root directory 
(%_datadir/eggdrop).

Version-Release number of selected component (if applicable):
Last release in Extras.

How reproducible:
[root@work eggdrop]# eggdrop -c /usr/share/eggdrop/eggdrop.conf

Eggdrop v1.6.18 (C) 1997 Robey Pointer (C) 2006 Eggheads
[23:32] * ERROR: Eggdrop will not run as root!

Additional info:
chown ircd:ircd /usr/share/eggdrop solves the issue.
Comment 1 Robert Scheck 2007-04-28 16:47:07 EDT
Configuration files NEVER have to be in /usr/share/eggdrop/, if you put them 
there, something is wrong with you. And there won't be any user shipped with 
eggdrop, because eggdrop is really thought to be MULTIPLE times started with 
DIFFERENT users and DIFFERENT configurations. Create an OWN user and put your 
configuration NOT into /usr/share/.

Note You need to log in before you can comment on or make changes to this bug.