This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 238291 - DadWifi Atheros Wireless (ath_pci) doesn't work
DadWifi Atheros Wireless (ath_pci) doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
http://madwifi.org/wiki/DadWifi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 17:30 EDT by Helge Deller
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 09:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Helge Deller 2007-04-28 17:30:09 EDT
Description of problem:
Since FC7 includes the new devicescape wireless stack, Networkmanager should 
at least work with the Atheros Dadwifi drivers. Currently Networkmanager does 
not even detect the ath_pci wlan0 driver and does not show any wireless 
selections.

Connecting with FC7 test4 by hand does work though.

How reproducible:
Always.

Steps to Reproduce:
1. Download dadwifi-openhal branch: 
http://madwifi.org/browser/branches/dadwifi-openhal
2. Build & install
3. modprobe ath_pci
4. run "iwconfig wlan0 channel 1"  (else it won't work, bug in 
dadwifi-openhal!)
5. modify the wpa_supplicant config file the standard way.
6. run wpa_supplicant with the "wext" 
driver:  "wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -Dwext -iwlan0"

Actual results:
This isn't different to other wifi drivers (beside no. 4) and as such it 
should work with NetworkManager as well...

Expected results:
Atheros dadwifi-openhal should work.
Comment 1 Helge Deller 2007-05-17 09:44:58 EDT
works now for me with latest updates:
- FC7 kernel 2.6.21-1.3149.fc7
- dadwifi-openhal branch with at least revision 2345
- latest FC7 networkmanager updates.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.