Bug 238292 - prism54 (softmac) wifi driver not supported by Networkmanager
Summary: prism54 (softmac) wifi driver not supported by Networkmanager
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL: http://prism54.org/newdrivers.html
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-28 21:42 UTC by Helge Deller
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 13:48:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Helge Deller 2007-04-28 21:42:18 UTC
Description of problem:
prism54 (softmac) wifi card is not detected/supported by Networkmanager.

How reproducible:
Allways.

Steps to Reproduce:
1. FC7 test4 includes the prism54_pci (softmac) wireless driver by default.
2. FC7 test4 does not have the needed firmware. (Download file 
http://prism54.org/firmware/2.7.0.0.arm and save as /lib/firmware/isl3886. 
Could this be shipped by RH Fedora by defaul? I assume not...)
3. modprobe prism54_pci
4. modify the wpa_supplicant config file the standard way.
6. run wpa_supplicant with the "wext" 
driver:  "wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -Dwext -iwlan0"
  
Actual results:
Does not work with Networkmanager at all, but with the steps above and running 
everything by hand it works.

Expected results:
prism54_pci softmac driver should work out of the box with NetworkManager, if 
the user provides the firmware himself to /lib/firmware/isl3886

Comment 1 Helge Deller 2007-05-17 13:48:26 UTC
prism54/softmac now works for me with Networkmanager and latest FC7 updates:
- FC7 kernel 2.6.21-1.3149.fc7 
- latest NetworkManager-0.6.5-2.fc7


Note You need to log in before you can comment on or make changes to this bug.