Bug 238328 - Inconsistency in provides breaks kmodtool
Inconsistency in provides breaks kmodtool
Status: CLOSED DUPLICATE of bug 227533
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-29 08:07 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-29 08:16:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2007-04-29 08:07:39 EDT
Description of problem:
Some kernels provide their variant with hyphen, some without:

$ grep "Provides: kernel-%{_target_cpu}" kernel-2.6.spec 
Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}smp
Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}PAE
Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}-PAE-debug
Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}-debug
Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xen
Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}kdump

IOW: the recently introduced kernel -PAE-debug and -debug use a hyphen after
%{release}, the older ones doesn't.

The hyphen breaks kmodtool, and thus all kmods that are build with it don't find
the proper kernel. 

Version-Release number of selected component (if applicable):
2.6.20-1.2944.fc6

How reproducible:
always

Suggested fix:
Remove the two hyphens please to make everything consistent again. Then kmodtool
(and probably other scripts out in the wild) will simply work again.

We of course could introduce stupid workarounds in kmodtool to get around this;
but getting rid of this inconsistency is the cleanest solution.
Comment 1 Ville Skyttä 2007-04-29 08:16:16 EDT
A patch that fixes this has been waiting for action in bug 227533 already for a
while...

*** This bug has been marked as a duplicate of 227533 ***

Note You need to log in before you can comment on or make changes to this bug.