Bug 238341 - gcc doesn't show up in package manager browser view
gcc doesn't show up in package manager browser view
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-29 12:37 EDT by hal
Modified: 2013-01-09 23:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 17:54:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hal 2007-04-29 12:37:06 EDT
Description of problem: gcc needs to be installed after installing fc7 from the live cd since it doesn't 
seem to be part of the basic installation.  But gcc doesn't show up in the pakage manager 
Development>Development tools optional package list.  It does seem to get installed as a result of 
something else (maybe ccache?).  But gcc, along with basic tools like perl and python do not show up in 
the browser view optional packages under development tools.  They are included in the list view that 
has everything.


Version-Release number of selected component (if applicable): fc7 test4 live CD


How reproducible: always


Steps to Reproduce:
1. Install fc7 from live CD
2. Open Applications > add/remove software
3. Select Development>Development tools and click on optional packages
  
Actual results: basic tools like perl, python, and gcc do not show up in the list. 


Expected results: gcc should be in this list to make it easy to find after a basic installation.  I would also 
expect to see things like perl and python there, and not just some of the packages that use these 
things.


Additional info:
Comment 1 Bill Nottingham 2007-05-01 00:55:07 EDT
If you choose development-tools, you get gcc, for what it's worth.

You get python and perl in the base system.
Comment 2 Jesse Keating 2007-05-01 11:59:31 EDT
I think the problem here is that we want gcc always when you select the tools,
thus it is mandatory.  If it's mandatory, it doesn't show up with a checkbox. 
Perhaps what pirut should do is display the mandatory packages in a
non-clickable way, with some indication if you already have said package or not.

Jeremy, your thoughts?
Comment 3 Jeremy Katz 2007-05-02 17:19:55 EDT
Showing mandatory packages doesn't necessarily take care of everything, though;
what about, eg, deps.  There's an open bug about potentially showing mandatory
packages in pirut, but I'm still leaning towards not.  Definitely not going to
change for F7 at this point
Comment 4 Jesse Keating 2007-05-22 17:54:56 EDT
Right now this is by design, closing this bug.  Re-open or add yourself to the
RFE about seeing mandatory packages in groups.
Comment 5 hal 2007-05-22 23:12:50 EDT
Not sure if it's more appropriate to continue this here or add to a RFE.  If it would be better to move it, 
could you give a reference to the apppropriate RFE? 

Whether or not we move it, I really only have a pretty simple scenario in mind.  After a default install, 
gcc isn't there, and when I go to the "obvious" place in the package installer it isn't there either.  Since I 
was new to this and don't really know about mandatory packages, I didn't realize that I'll get gcc if I 
install most anything in the developer tools section.

So I don't know if the answer is to include in the list some of the very high-level things that people 
might want, like gcc, or to somehow make it more apparent which mandatory packages will get 
installed automatically.  The answer probably isn't to show all the potential dependencies, since there is 
a lot of clutter there.  But it would help to show gcc, for example, with a greyed-out, already-checked 
checkbox so I know it's there.

Anyway, I don't want to beat this to death, but it does seem to be something that could be done a bit 
better to help out new users.

Note You need to log in before you can comment on or make changes to this bug.