This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 238350 - Kernel bug syslog messages
Kernel bug syslog messages
Status: CLOSED DUPLICATE of bug 234008
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-29 14:51 EDT by Bruno Wolff III
Modified: 2009-12-14 15:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 09:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Messages from the rawhide instance. (221.62 KB, text/plain)
2007-04-29 14:51 EDT, Bruno Wolff III
no flags Details
Output of lspci -v (11.23 KB, text/plain)
2007-04-29 14:52 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2007-04-29 14:51:00 EDT
Description of problem:
I received several kernel bug syslog messages while testing rawhide from April 27th.

For example:
Apr 29 12:38:07 bruno kernel: BUG: at kernel/fork.c:994 copy_process()
Apr 29 12:42:04 bruno kernel:  <3>BUG: sleeping function called from invalid
context at kernel/rwsem.c:20
Apr 29 12:54:14 bruno kernel: BUG: at kernel/fork.c:994 copy_process()
Apr 29 12:57:43 bruno kernel: BUG: at kernel/lockdep.c:1858 trace_hardirqs_on()
Apr 29 13:07:24 bruno kernel: BUG: unable to handle kernel paging request at
virtual address e88df00c
Apr 29 13:07:28 bruno kernel:  <3>BUG: sleeping function called from invalid
context at kernel/rwsem.c:20
Apr 29 13:13:32 bruno kernel: BUG: unable to handle kernel NULL pointer
dereference at virtual address 00000000
Apr 29 13:17:15 bruno kernel: BUG: at kernel/fork.c:994 copy_process()


Version-Release number of selected component (if applicable):
2.6.20-2925.5.fc7xen

How reproducible:
Unknown

Steps to Reproduce:
1. I don't know.
2.
3.
  
Actual results:
Kernel bug syslog messages

Expected results:
No kernel bug syslog messages

Additional info:
Comment 1 Bruno Wolff III 2007-04-29 14:51:00 EDT
Created attachment 153741 [details]
Messages from  the rawhide instance.
Comment 2 Bruno Wolff III 2007-04-29 14:52:41 EDT
Created attachment 153742 [details]
Output of lspci -v
Comment 3 Eduardo Habkost 2007-10-11 09:03:08 EDT
The Oops looks like bug #234008. Could you confirm if the problem is gone with 
a newer kernel (the latest kernel on either FC-6, F-7 or Rawhide).
Comment 4 Bruno Wolff III 2007-10-13 13:59:49 EDT
I tried 2.6.20-2936.fc7xen and didn't see the problem. The string 'BUG' did not
appear in the syslog entries from the boot and for the short (a couple of
minutes) I was running with this kernel nothing odd happened. I tried it on the
same machine as I had previously had the problem on.
Comment 5 Eduardo Habkost 2007-10-15 09:46:19 EDT

*** This bug has been marked as a duplicate of 234008 ***

Note You need to log in before you can comment on or make changes to this bug.