Bug 238365 - Suspend Leaves Machine Unusable
Summary: Suspend Leaves Machine Unusable
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard: bzcl34nup
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-29 20:56 UTC by Daryll
Modified: 2008-04-04 00:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 00:28:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daryll 2007-04-29 20:56:57 UTC
Description of problem:
Using Fedora 7 test4
Kernel: 2.6.21-1.3116.fc7
HP Core 2 Duo Laptop DV9000

Closing the lid is set to suspend to RAM.
The system appears to suspend to RAM correctly. 
The power light blinks, showing sleep, and the wifi light goes to orange,
showing disabled.
Opening the lid and pressing a key starts to restore the system.
I see the disk flashes for a short period.
The power light goes solid blue indicating on.
The wifi light changes to blue, indicating on.
The display remains dark.

From looking at /var/log/messages it seems to get to setting clock with NTP then
the following is logged:
Apr 29 11:25:12 ninja kernel: BUG: soft lockup detected on CPU#1!
Apr 29 11:25:12 ninja kernel:  [<c04061e9>] show_trace_log_lvl+0x1a/0x2f
Apr 29 11:25:12 ninja kernel:  [<c04067ad>] show_trace+0x12/0x14
Apr 29 11:25:12 ninja kernel:  [<c0406831>] dump_stack+0x16/0x18
Apr 29 11:25:12 ninja kernel:  [<c04588b9>] softlockup_tick+0xa8/0xba
Apr 29 11:25:12 ninja kernel:  [<c042f3cb>] run_local_timers+0x12/0x14
Apr 29 11:25:12 ninja kernel:  [<c042f7b6>] update_process_times+0x3e/0x63
Apr 29 11:25:12 ninja kernel:  [<c043ee8b>] tick_sched_timer+0x5d/0xa1
Apr 29 11:25:12 ninja kernel:  [<c043b56e>] hrtimer_interrupt+0x128/0x1b2
Apr 29 11:25:12 ninja kernel:  [<c0419f41>] smp_apic_timer_interrupt+0x72/0x84
Apr 29 11:25:12 ninja kernel:  [<c0405b3b>] apic_timer_interrupt+0x33/0x38
Apr 29 11:25:12 ninja kernel:  [<c04033ed>] cpu_idle+0xab/0xcc
Apr 29 11:25:12 ninja kernel:  [<c0418efd>] start_secondary+0x330/0x338
Apr 29 11:25:12 ninja kernel:  [<00000000>] 0x0

Comment 1 Daryll 2007-05-15 23:49:38 UTC
 2.6.21-1.3142 Suspends properly on my laptop.


Comment 2 Daryll 2007-05-24 14:47:57 UTC
kernel-2.6.21-1.3189.fc7 seems to suspend correctly. The system goes to sleep
and the power light blinks. But the system fails to restore. When I open the lid
the power light turns solid blue, but there appears to be no other action. I
don't see any disk activity and there is nothing logged.


Comment 3 Daryll 2007-07-18 15:17:16 UTC
2.6.22.1-20.fc7 from upgrades-testing seems to be winning. It is successfully
powering suspending and resuming.


Comment 4 Bug Zapper 2008-04-04 00:22:28 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 5 Daryll 2008-04-04 00:28:08 UTC
No longer a bug. Works fine with Fedora 8 kernels.



Note You need to log in before you can comment on or make changes to this bug.