Bug 238368 - FC7T4 installation failure
FC7T4 installation failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-29 17:13 EDT by Stephen Haffly
Modified: 2008-04-08 13:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 13:00:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Haffly 2007-04-29 17:13:53 EDT
Description of problem:  Installation of FC7T4 DVD fails


Version-Release number of selected component (if applicable):  FC7T4


How reproducible:  Boot with FC7T4 DVD and select to install/upgrade with
graphical installer.  When it launches anaconda, it fails and shuts the system down.


Steps to Reproduce:
1.  Boot with FC7T4 DVD
2.  Select to install/upgrade using graphical installer
3.  message:  Running anaconda, the Fedora system installer -please wait...
4.  message:  /usr/bin/python: error while loading shared libraries:
/lib/libpthread.so.0: invalid ELF header
5.  message:  install exited abnormally [1/1]
6.  system performs shutdown

Actual results:  Installation terminates abnormally with messages detailed above.


Expected results:  Installation should proceed to next steps and conclude with
complete installation.


Additional info:  This is consistent across multiple attempts to install from
the DVD.  The only way I was able to install FC7T3 was to use the Live CD.
Comment 1 Jeremy Katz 2007-04-30 14:29:10 EDT
Did you verify your installation media?
Comment 2 Stephen Haffly 2007-05-01 11:21:10 EDT
Originally, I had skipped verification.  I did the media verification for this
attempt.

The media verifies.

I got a bit further after verifying it this time.

It passed the "Running Anaconda" this time and continued with this:

Probing for videocard:  nVidia Corporation NV34 [GeForce FX5200]
Attempting to start native X server
Waiting for X server to start...log located in /tmp/ramfs/X.log
1...2...3...4...5...X server started successfully
Traceback (most recent call last):
     File "/usr/bin/anaconda", line 831, in <module>
          if xserver_pid is not None and badEDID(xserver.logfile):
     File "/usr/bin/anaconda", line 457, in badEDID
          f = open(logfile, "r")
IO Error: [Errno 2] No such file or directory: '/tmp/ramfs/X.log'

This was all hand copied from the screen.  At the last line above, the system
sits frozen.

I just rebooted again.  This time, it went to the Install screen and the
pre-release warning and proceeded.  I interrupted it and did a cold start.  It
failed with the same error as I just detailed above.

Another try resulted it in siting at the X on the patterned background.

Another try and it finally installed (actually, did the upgrade from T3.

Failure seems to be at different points.  Eventually, it did work, but not
everyone would have the patience to keep trying until it does.

Sytem is an Athlon XP 2600+ on an  ECS KT600-A motherboard with 1GB RAM.  The
graphics card is AGP.

Sorry to be so long getting back to you.  Work requirements delayed me being
able to experiment with it.
Comment 3 Jeremy Katz 2007-09-21 14:16:59 EDT
Did this happen with Fedora 7 final?  
Comment 4 Bug Zapper 2008-04-03 20:22:40 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 Stephen Haffly 2008-04-08 12:48:22 EDT
This is now a moot point.  Fedora 8 did not have the installation issues that
Fedora 7 test4 had.  Please mark this one as resolved.

Note You need to log in before you can comment on or make changes to this bug.