Bug 238381 - Network install via FTP fails when source name has characters that need an escape sequence
Network install via FTP fails when source name has characters that need an es...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-04-29 21:07 EDT by Nick Sharp
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 15:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Sharp 2007-04-29 21:07:05 EDT
Forgive me, I have replaced the template with all my notes!...

Frequently, I install Fedora via my LAN.  If the release ISO image is on MAC OS
X 10.4, I seem NOT to be able to mount that ISO in my usual way on Fedora:

mount -o loop -t iso9660 <image> <mount-directory>

On MAC mount ain't mount!

Instead, I simply double click on the ISO and OS X uses DiskImageMounter to
mount it as a virtual disk which can be found in /Volumes

However, if I use for example the image:
F-6.93-i386-DVD.iso
I get a virtual disk named with exactly these 16 characters:
"Fedora 6.93 x86

FTP is enabled on the MAC.  I can then FTP access components of the release, BUT
the volume name has been derived by truncating the ISO label (in the example:
"Fedora 6.93 x86_64 DVD"), not simply taking the ISO image full name.

You can see this if you use isomaster to open image F-6.93-i386-DVD.iso then
click properties you read that the volume name is literally all these characters:

"Fedora 6.93 x86_64 DVD"

that is, it really does include two double-quote marks and three spaces (%=((. 
When on the MAC you double click the image, a virtual disk appears named with
exactly these 16 characters:

"Fedora 6.93 x86

Yuk!  If you wish to access components using a standard client FTP, you have in
FTP to cd to precisely:

/Volumes/\"Fedora\ 6.93\ x86

If you wanted to use that virtual disk to do a network install across your LAN,
you would THINK you need to enter the above in the Fedora Directory box in the
FTP details window.  It does not work.  

One work around is to download the ISO on a Linux machine, use isomaster to
alter the volume name to 16 standard characters (that do not need an escape \
sequence), SAVE (all 3Gb!) AS new filename, and FTP that to the MAC, if you want
to keep your ISOs on the MAC.  I find it handy as the MAC is particularly good
and easy to use for burning disks.

Then at the MAC, mount the new image by double clicking.  The virtual disk will
now carry the new volume name.  I used Fedora6.93x86_64

A network install now proceeds normally.  What a fight!  Proprietary systems eh?
 Hmmph!

Running tcpdump on the MAC suggests as follows:

If you use a standard client to GET a small test file such as GPL, you need:

get /Volumes/\"Fedora\ 6.93\ x86/GPL

which works.  The tcpdump suggests that this request is treated as special, and
is sent as an SRETR in which the entire file path and name are enclosed in
single quote marks and the escape sequences are removed.  Since the install
dialogue seeks only a partial name - with the installer adding additional path
details and a file name - you cannot enter single quotes tot he installer.

Solutions?:
Users:
1	Don't use silly servers
2	Fix up the hidden name with isomaster on Linux before filing on the MAC (very
boring)
3	On the MAC copy the contents of the virtual disk to a nicely named directory
and use that instead (rather boring)
Fedora team:
4	In the ISO volume name, use max 16 characters none of which require escaping
(cheap cheerful and effective)
EG F693x86_64DVD, F693i386DVD, and so on
5	Alter the installer to be smart with nasty volume names (best solution but is
it worth it?)

but at least document why it doesn't work so that others do not beat out their
brains!
Comment 1 Jesse Keating 2007-09-04 15:55:49 EDT
I assigned this to pungi as pungi is the overall tree builder for Fedora.

I'm closing this wontfix as a fuller easy to read volume ID was requested of us
in the past and I'm inclined to leave it as it is.  Setting up the isos to be
served via a file system you can easily create a symlink to the volume mount and
share it, you can mount by hand and mount it to a directory of your choosing, or
whatever else.  The value of having human readable volume IDs outweighs the
slight problem of OSX mounting by volume name and you wanting to serve that via
the Finder mount.

Note You need to log in before you can comment on or make changes to this bug.