Bug 238393 - network unreachable with qemu/kvm
network unreachable with qemu/kvm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 00:58 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 20:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-04-30 00:58:51 EDT
Description of problem:
If I start a qemu guest OS in rawhide it seems the network connection
on eth0 is unreachable.  I guess the bridge is not working correctly.

How reproducible:
every time

Steps to Reproduce:
1. try to install FC6 via http as a guest OS
  
Actual results:
Can't connect to http mirror.

Expected results:
Network connection to work like under xenbr.

Additional info:
I configure the qemu guest network to be "Virtual network -> default"
since "Shared physical device" shows no devices.
Comment 1 Daniel Berrange 2007-05-01 11:40:54 EDT
Can you tell me what kernel version is being used in the guest OS ? The most
likely reason for the broken connectivity is a kernel bug todo with checksumming.

You can verify this theory by doing:

In the host:

  ethtool -K virbr0  tx off

And in the guest:

  ethtool -K eth0 tx off

With both those disabled, networking should work.  The real fix will be done in
the kernel-xen RPM.
Comment 2 Jens Petersen 2007-05-01 20:13:10 EDT
(BTW I am running qemu with kernel-2.6.21-1.3116.fc7.x86_64 and kvm.)

Yum upgrading to the latest rawhide today pulled in dnsmasq and networking
is working now. :)
Comment 3 Jens Petersen 2007-05-01 20:48:02 EDT
However I am still not able to do a network install of guests for qemu.
Comment 4 Jens Petersen 2007-05-01 23:11:04 EDT
BTW is kernel-xen required for networking with qemu?

(I ran "ethtool -K virbr0  tx off" on the host but
couldn't run "ethtool -K eth0 tx off" on a rhel5 qemu guest.)

> However I am still not able to do a network install of guests for qemu.

Actually after rebooting again everything *is* working now. <shrug/>

Note You need to log in before you can comment on or make changes to this bug.