Bug 238393 - network unreachable with qemu/kvm
Summary: network unreachable with qemu/kvm
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-30 04:58 UTC by Jens Petersen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-05-02 00:13:10 UTC


Attachments (Terms of Use)

Description Jens Petersen 2007-04-30 04:58:51 UTC
Description of problem:
If I start a qemu guest OS in rawhide it seems the network connection
on eth0 is unreachable.  I guess the bridge is not working correctly.

How reproducible:
every time

Steps to Reproduce:
1. try to install FC6 via http as a guest OS
  
Actual results:
Can't connect to http mirror.

Expected results:
Network connection to work like under xenbr.

Additional info:
I configure the qemu guest network to be "Virtual network -> default"
since "Shared physical device" shows no devices.

Comment 1 Daniel Berrange 2007-05-01 15:40:54 UTC
Can you tell me what kernel version is being used in the guest OS ? The most
likely reason for the broken connectivity is a kernel bug todo with checksumming.

You can verify this theory by doing:

In the host:

  ethtool -K virbr0  tx off

And in the guest:

  ethtool -K eth0 tx off

With both those disabled, networking should work.  The real fix will be done in
the kernel-xen RPM.


Comment 2 Jens Petersen 2007-05-02 00:13:10 UTC
(BTW I am running qemu with kernel-2.6.21-1.3116.fc7.x86_64 and kvm.)

Yum upgrading to the latest rawhide today pulled in dnsmasq and networking
is working now. :)

Comment 3 Jens Petersen 2007-05-02 00:48:02 UTC
However I am still not able to do a network install of guests for qemu.

Comment 4 Jens Petersen 2007-05-02 03:11:04 UTC
BTW is kernel-xen required for networking with qemu?

(I ran "ethtool -K virbr0  tx off" on the host but
couldn't run "ethtool -K eth0 tx off" on a rhel5 qemu guest.)

> However I am still not able to do a network install of guests for qemu.

Actually after rebooting again everything *is* working now. <shrug/>


Note You need to log in before you can comment on or make changes to this bug.