Bug 238399 - "internal compiler error: Segmentation fault" when using -fopenmp
"internal compiler error: Segmentation fault" when using -fopenmp
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc4 (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 04:35 EDT by Sebastian Steiger
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHEA-2007-0805
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:11:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The preprocessed code which gives the error (1.04 MB, application/octet-stream)
2007-04-30 04:35 EDT, Sebastian Steiger
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 30558 None None None Never

  None (edit)
Description Sebastian Steiger 2007-04-30 04:35:12 EDT
Description of problem:
-----------------------

When compiling a certain parallelized code using -fopenmp, an internal compiler
error occurs. Unfortunately I cannot track the problem down more because as soon
as I take away some include files or further simplify my code, the error disappears.


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gcc version 4.1.0 20060515 (Red Hat 4.1.0-18) 
(using libgomp)


How reproducible:
-----------------
Always (on my x86_64 machine)


Steps to Reproduce:
-------------------
1. Take the supplied preprocessed file test.cpp
2. Try to compile: g++4 -c -Wall -fPIC -g -DDEBUG -DAMD -m64 -fopenmp -o test.o
test.cpp 

  
Actual results:
---------------
- Compiling gives an internal compiler error
- When omitting -fopenmp, compiling works

Expected results:
-----------------
Compiling using OpenMP (libgomp) should also work!
Comment 1 Sebastian Steiger 2007-04-30 04:35:13 EDT
Created attachment 153775 [details]
The preprocessed code which gives the error
Comment 2 Jakub Jelinek 2007-04-30 05:02:40 EDT
Incidentally I have fixed this last week, see
http://gcc.gnu.org/PR30558
http://gcc.gnu.org/ml/gcc-patches/2007-04/msg01601.html
The fix is so far in gcc-4.1.2-11 in Fedora development (i.e. will be in Fedora
7), but will eventually make it to other distros which track
redhat/gcc-4_1-branch (RHEL5.1, RHEL4.6, FC6, FC5).
Comment 9 errata-xmlrpc 2007-11-15 11:11:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0805.html

Note You need to log in before you can comment on or make changes to this bug.