Bug 238410 - FC7-T4 Problem with ATA66 module.
FC7-T4 Problem with ATA66 module.
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-04-30 07:33 EDT by Joshua
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-21 13:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg from FC5 where there is no problem (17.06 KB, text/plain)
2007-04-30 07:33 EDT, Joshua
no flags Details
lspci -vvxxx output from FC5 (19.35 KB, text/plain)
2007-04-30 07:36 EDT, Joshua
no flags Details
dmesg from FC7-t4 where the problem is (17.49 KB, text/plain)
2007-04-30 07:54 EDT, Joshua
no flags Details
Proposed fix (1.49 KB, patch)
2007-05-01 08:01 EDT, Alan Cox
no flags Details | Diff

  None (edit)
Description Joshua 2007-04-30 07:33:16 EDT
Description of problem: pata_hpt66 module fails to initialize onboard Highpoint
ATA66 controller.

Version-Release number of selected component (if applicable):

How reproducible:
It fails on every boot and will not boot if drives on the controller (hde hdg)
are listed in fstab.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Joshua 2007-04-30 07:33:16 EDT
Created attachment 153782 [details]
dmesg from FC5 where there is no problem
Comment 2 Joshua 2007-04-30 07:36:51 EDT
Created attachment 153785 [details]
lspci -vvxxx output from FC5
Comment 3 Joshua 2007-04-30 07:54:36 EDT
Created attachment 153787 [details]
dmesg from FC7-t4 where the problem is
Comment 4 Alan Cox 2007-05-01 07:18:25 EDT
Bug identified - just testing a patch now. It got broken in the move to iomaps.
Comment 5 Alan Cox 2007-05-01 08:01:57 EDT
Created attachment 153855 [details]
Proposed fix
Comment 6 Alan Cox 2007-05-01 12:33:14 EDT
Patch send to DaveJ, and stable tree after checking with Tejun Heo

Not going into the dev tree as further rewriting of the port registration code
has already fixed this by accident
Comment 7 Alan Cox 2007-05-21 13:09:18 EDT
Resolved upstream and in stable

Note You need to log in before you can comment on or make changes to this bug.