Bug 238414 - [NetApp-S 5.2 feat] iscsi lun resize dosen't take effect without a restart
[NetApp-S 5.2 feat] iscsi lun resize dosen't take effect without a restart
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.2
All Linux
low Severity high
: ---
: ---
Assigned To: Mike Christie
: FutureFeature, OtherQA
Depends On:
Blocks: 217208 249267 296431 372911
  Show dependency treegraph
 
Reported: 2007-04-30 08:05 EDT by Ritesh Raj Sarraf
Modified: 2009-06-19 12:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.1.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 22:00:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ritesh Raj Sarraf 2007-04-30 08:05:21 EDT
Description of problem:

Currently, when resizing a LUN on the filer, from say 40G to 50G, the changes 
aren't reflected on the host.
For example, you started the iscsid daemon and mapped a LUN of size 40G.
Then you resize the LUN on the filer to 50G. Now if you reload (using 
iscsiadm) the iscsi service, still the LUN is reported of size 40G on the 
host.
To get the newly updated size  a restart of the iscsid daemon is required 
which is disruptive is other LUNs are also mapped and mounted.


Version-Release number of selected component (if applicable):
RHEL5

How reproducible:
Very Reproducible

Steps to Reproduce:
1. Start the iscsid service mapping a LUN.
2. Now resize the LUN on the filer.
3. Do an iscsi reload on the host.
4. The LUN size reported is still the old size
  
Actual results:
The LUN is still reported to be of the older size.

Expected results:
The new LUN size should be reported on a reload
Comment 1 Mike Christie 2007-04-30 14:00:54 EDT
You can actually just do:
echo 1 > /sys/block/sdX/device/rescan

I think we are adding or have added a tool which does that for you, which is not
iscsi specific since we want this functionality for all pretty much any driver.
But when that is done and when "iscsi reload" is implemented I can hook it in.

Did you make a BZ for RHEL4 too?
Comment 2 Andrius Benokraitis 2007-04-30 14:08:47 EDT
Mike - see bug 238413 for a request for RHEL 4.6.
Comment 3 RHEL Product and Program Management 2007-04-30 14:27:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Andrius Benokraitis 2007-06-28 09:58:19 EDT
Unfortunately, all features need to be included prior to Beta, and this internal
deadline has passed. Moving to 5.2.
Comment 9 Andrius Benokraitis 2007-10-18 00:54:43 EDT
Mike - any updates to this bugzilla for 5.2 consideration?
Comment 10 Mike Christie 2007-10-18 17:23:24 EDT
We can probably just close this. Some code slipped into 5.1 and you can do

iscsiadm -m node -T target -p portal --rescan

or

iscsiadm -m node --rescan

or

iscsiadm -m session --rescan

or

one of the other possible combos.

Netapp please see the README and man pages for --rescan use and try it out.
Comment 11 Andrius Benokraitis 2007-10-18 22:00:23 EDT
NetApp: Please try RHEL 5.1, and reopen this bug if needed.

Note You need to log in before you can comment on or make changes to this bug.