Bug 238429 - Incorrect detection of multiple plaintexts
Incorrect detection of multiple plaintexts
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnupg (Show other bugs)
4.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tomas Mraz
: Regression
Depends On: 234087
Blocks: 442815
  Show dependency treegraph
 
Reported: 2007-04-30 09:43 EDT by Sachin Prabhu
Modified: 2010-10-22 10:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-07 23:56:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for gnupg-1.2.6-9 copied from bz 234087 (1.37 KB, patch)
2007-04-30 09:43 EDT, Sachin Prabhu
no flags Details | Diff

  None (edit)
Description Sachin Prabhu 2007-04-30 09:43:46 EDT
+++ This bug was initially created as a clone of Bug #234087 +++

Description of problem:
When decrypting multiple GPG encrypted files with --multifile --decrypt (or
--decrypt-files), I get "gpg: WARNING: multiple plaintexts seen" warnings for
all but the first file in the list.  Furthermore, decryption fails with the
message "gpg: handle plaintext failed: unexpected data" on all but the first
file unless I give it the --allow-multiple-messages option.  But even then, I
still get the warning messages.  

All files in the list have been encrypted with gnupg, verified with 'file' as
"GPG encrypted data", and are not plain text.  

Version-Release number of selected component (if applicable):
gpg (GnuPG) 1.4.7


How reproducible:
Completely reproducible.

Steps to Reproduce:
1. Create a subdir with several files.
2. Encrypt all files in the subdir with gnupg; remove originals
3. Attept to decrypt all files at once with 'gpg --multifile --decrypt *'
  
Actual results:
Only the first file in the shell expansion list of '*' gets decrypted.  The rest
generate the warning message "gpg: WARNING: multiple plaintexts seen" ans well
as a line indicating that decryption failed.  Using --allow-multiple-messages
will cause the files to be decrypted, but the warning message persists.

Expected results:
All files decrypted successfully with no warnings or errors.

Additional info:

-- Additional comment from dshaw@jabberwocky.com on 2007-04-16 23:09 EST --
Created an attachment (id=152736)
Bug fix

Here's a patch.  It'll be in 1.4.8.

-- Additional comment from mobleym@gmail.com on 2007-04-17 14:07 EST --
Just tested patch -- works fine.  Thanks!

--mgm
Comment 1 Sachin Prabhu 2007-04-30 09:43:46 EDT
Created attachment 153795 [details]
Patch for gnupg-1.2.6-9 copied from bz 234087
Comment 2 Sachin Prabhu 2007-04-30 09:45:59 EDT
Regression noticed after upgrading from 'gnupg-1.2.6-8'to 'gnupg-1.2.6-9".
Comment 4 RHEL Product and Program Management 2008-04-16 07:53:57 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 10 Subhendu Ghosh 2010-09-07 23:56:50 EDT
The issue is cosmetic: decryption works with the --allow-multiple-messages
option.

Closing bug.

Note You need to log in before you can comment on or make changes to this bug.