This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 238456 - KOrganizers recurrance doesn't work quite right
KOrganizers recurrance doesn't work quite right
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdepim (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 14:03 EDT by Jay Turner
Modified: 2015-07-13 13:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 14:04:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2007-04-30 14:03:04 EDT
Description of problem:
I'm seeing this with kdepim-3.5.4-4.fc6 and there's an outside chance this is
just evolution not understanding kdepims format, but alas here's the issue.

Schedule a recurring meeting for a day/time and invite someone for which the
meeting will actually fall on a different day (i.e. a 6:00 Brisbane meeting will
be 16:00 the previous day in RDU)  Send out the meeting request and it will look
like this:

RRULE:FREQ=WEEKLY;BYDAY=TU
DTSTART:20070430T200000Z
DTEND:20070430T210000Z

Accepting this meeting in evolution will result in an entry being made for 16:00
on 4/30 (a Monday, which is totally correct) but you'll also get an entry for
5/1 (Tuesday) at 16:00 and every Tuesday from then on will get a 16:00 meeting.
 I suspect the cause of the problem is the fact that the invite has the start
and end times in zulu, but the BYDAY designator is in local time for the meeting
scheduler (which in this case was Brisbane.)  Contrast this with evolution's
handling of the same meeting . . . evolution lists the start, end and repeat day
in local time of the scheduler.
Comment 1 Jay Turner 2007-04-30 14:03:58 EDT
QE ack for RHEL5.1.
Comment 2 RHEL Product and Program Management 2007-05-10 13:25:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Pete Graner 2007-05-10 14:48:01 EDT
Doing a KDE & QT push for 5.2, targeting for 5.2, clearing acks.
Comment 4 Jay Turner 2007-09-05 11:21:03 EDT
QE ack for RHEL5.2.
Comment 5 RHEL Product and Program Management 2007-12-03 15:42:31 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.

Note You need to log in before you can comment on or make changes to this bug.